Bug 114908 - netscroll+ driver completely unusable
Summary: netscroll+ driver completely unusable
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: XFree86   
(Show other bugs)
Version: 1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-04 12:52 UTC by Raphael Clifford
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-09 17:16:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Raphael Clifford 2004-02-04 12:52:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
If you run redhat-config-mouse and choose Genius Netscroll+ mouse and
then restart X the mouse becomes unusable. (The mouse is an Optical
Genius Netscroll+ mouse.)  

In detail this means

The mouse pointer appears in the bottom left. If you attempt to move
it it goes about a quarter of the way across the screen then flits
about randomly "clicking" on random thing. 

However, if you choose "Generic 3 button PS/2" everything works just fine.

Version-Release number of selected component (if applicable):
XFree86 4.3.0

How reproducible:
Always

Steps to Reproduce:
1. Run redhat-config-mouse and choose Genius Netscroll+ mouse 
2. Restart X 
3. Move mouse pointer
    

Actual Results:  The mouse pointer appears in the bottom left. If you
attempt to move it it goes about a quarter of the way across the
screen then flits about randomly "clicking" on random thing.

Expected Results:  It should function as normal

Additional info:

The "Generic 3 button PS/2"  works just fine for me Genius Netscroll+
mouse.

Comment 1 Mike A. Harris 2004-02-07 10:32:52 UTC
Try using a different mouse protocol instead.  You will need to
reboot your computer after changing the protocol configuration
because PS/2 and serial mouse hardware often hang if the wrong
protocol is chosen, and only a hardware reset fixes it.

If you can't get the mouse to work at all, then I recommend
reporting this as a bug to XFree86.org and seeking technical
assistance on the XFree86 mailing lists.


Comment 2 Raphael Clifford 2004-02-07 14:32:41 UTC
As reported above it does work when you choose "Generic 3 button PS/2". 

I have reported it at http://bugs.xfree86.org/show_bug.cgi?id=1145

Comment 3 Mike A. Harris 2004-02-07 15:16:58 UTC
I assume the "scroll" part of the mouse does not work if you use
Generic PS/2?

Comment 4 Raphael Clifford 2004-02-09 17:00:25 UTC
The scroll does appear to work with "Generic 3 button PS/2"

Comment 5 Mike A. Harris 2004-02-09 17:16:31 UTC
Ok, I think we can consider this to be NOTABUG then.  It's possible
that the "netmouse" entry present is for another different model of
netmouse or something, and that yours is not the same.  Since it
works with Generic 3 button, it's safe to consider that to be the
proper configuration.

Thanks.

Closing NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.