Bug 114913 - kernel 2.6.1 and modprobe sound-slot-0 gives error
kernel 2.6.1 and modprobe sound-slot-0 gives error
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: modutils (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-04 08:56 EST by anthony baxter
Modified: 2014-03-16 22:41 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.4.26-15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-15 22:24:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description anthony baxter 2004-02-04 08:56:59 EST
Description of problem:

I dropped kernel 2.6.1-65 onto my Dell Inspiron 5150, and the
configuration that auto-probed the sound card no longer works.

Relevant entries from modules.conf:
alias char-major-14 soundcore
alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-card-0

modprobe sound-slot-0 returns 
FATAL: Module sound_slot_0 not found.

modprobe snd-intel8x0 works fine, though.


Version-Release number of selected component (if applicable):

kernel 2.6.1-65
modutils-2.4.26-3


How reproducible:

Always - boot, try to modprobe the sound card
Comment 1 anthony baxter 2004-02-04 09:00:41 EST
dmesg has these messages:
request_module: failed /sbin/modprobe -- sound-slot-0. error = 256
        -0091: *** Error: ut_allocate: Attempt to allocate zero bytes
        -0091: *** Error: ut_allocate: Attempt to allocate zero bytes
        -0091: *** Error: ut_allocate: Attempt to allocate zero bytes
        -0091: *** Error: ut_allocate: Attempt to allocate zero bytes
request_module: failed /sbin/modprobe -- sound-slot-0. error = 256
Comment 2 Bill Nottingham 2004-02-04 10:14:33 EST
If you just change it to:

alias sound-slot-0 snd-intel8x0

does it work?
Comment 3 anthony baxter 2004-02-04 10:50:51 EST
Nope, same error (with the dashes being replaced with underscores in
the error message).
Comment 4 Patrick Lawrence 2004-02-16 18:12:49 EST
I'm also having a problem with sound on a Shuttle SN45G (NForce2).

[root@cantrell root]# lsmod
Module                  Size  Used by
snd_pcm_oss            52900  0
snd_mixer_oss          18304  2 snd_pcm_oss
snd_intel8x0           34564  2
snd_ac97_codec         52612  1 snd_intel8x0
snd_pcm               111880  2 snd_pcm_oss,snd_intel8x0
snd_timer              32388  1 snd_pcm
snd_page_alloc         11652  2 snd_intel8x0,snd_pcm
snd_mpu401_uart         9984  1 snd_intel8x0
snd_rawmidi            28832  1 snd_mpu401_uart
snd_seq_device          8328  1 snd_rawmidi
snd                    55012  11
snd_pcm_oss,snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore              10720  2 snd
md5                     4224  1
ipv6                  263552  10
lp                     12652  0
autofs                 16512  0
nfs                   165180  3
lockd                  62152  1 nfs
sunrpc                157768  9 nfs,lockd
forcedeth              18688  0
sg                     36120  0
scsi_mod              124600  1 sg
parport_pc             39724  1
parport                47336  2 lp,parport_pc
ohci1394               41860  0
ieee1394              284464  1 ohci1394
radeon                126764  2
ide_cd                 39428  0
cdrom                  37020  1 ide_cd
ohci_hcd               23552  0
ehci_hcd               29828  0
usbcore               119388  4 ohci_hcd,ehci_hcd
thermal                13200  0
processor              13988  1 thermal
fan                     4108  0
button                  6168  0
battery                 8972  0
asus_acpi               9368  0
ac                      4876  0
ext3                  128424  5
jbd                    86040  1 ext3
dm_mod                 41760  6
[root@cantrell root]# dmesg
<snip>
intel8x0: clocking to 47378
request_module: failed /sbin/modprobe -- sound-slot-0. error = 256
[root@cantrell root]# kudzu -p --class=AUDIO
-
class: AUDIO
bus: PCI
detached: 0
driver: snd-intel8x0
desc: "nVidia Corporation|nForce2 AC97 Audio Controler (MCP)"
vendorId: 10de
deviceId: 006a
subVendorId: 1297
subDeviceId: f541
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  6
pcifn:  0
-
class: AUDIO
bus: PCI
detached: 0
driver: unknown
desc: "nVidia Corporation|nForce MultiMedia audio [Via VT82C686B]"
vendorId: 10de
deviceId: 006b
subVendorId: 1297
subDeviceId: f541
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  5
pcifn:  0

Please let me know if there is anything that you want/need me to test.

Regards,

Pat
Comment 5 Patrick Lawrence 2004-02-16 18:13:54 EST
Oh yeah....

[root@cantrell root]# cat /etc/modprobe.conf
 
include /etc/modprobe.conf.dist
alias eth0 forcedeth
alias usb-controller ehci-hcd
alias usb-controller1 ohci-hcd
alias ieee1394-controller ohci1394
 
# ALSA portion
alias char-major-116* snd
alias snd-card-0 snd-intel8x0
 
# OSS/Free portion
alias char-major-14* soundcore
 
# card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
 
install snd-card-0 /sbin/modprobe --ignore-install snd-card-0 && {
/usr/sbin/alsactl restore >/dev/null 2>&1 || :; }
remove snd-card-0 { /usr/sbin/alsactl store >/dev/null 2>&1 || :; };
/sbin/modprobe -r --ignore-remove
 
#alias sound-slot-0 snd-intel8x0
#install sound-slot-0 /sbin/modprobe --ignore-install sound-slot-0 &&
/bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
alias sound-slot-0 snd-intel8x0
install sound-slot-0 /sbin/modprobe --ignore-install sound-slot-0 &&
/bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
Comment 6 Bill Nottingham 2004-04-15 22:24:35 EDT
OK, the only part of this that is a modutils issue is that

alias snd-card-0 <foo>
alias sound-slot-0 snd-card-0

won't work, because you can't have an alias to an alias.

This is worked around in modutils-2.4.26-15 (where you will only need
the snd-card-0 alias).

The rest of these sound more like kernel driver issues; if those
persist, please open new bugs.

Note You need to log in before you can comment on or make changes to this bug.