Bug 114922 - rhn_register fails to register, errors in hardware.py and tui.py
rhn_register fails to register, errors in hardware.py and tui.py
Status: CLOSED DUPLICATE of bug 113599
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: rhn_register (Show other bugs)
2.1
i386 Linux
high Severity low
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-04 11:32 EST by Michael Balderas
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Balderas 2004-02-04 11:32:24 EST
Description of problem:
While running rhn_register from the console I get the following:
Traceback (innermost last):
  File "/usr/sbin/rhn_register", line 233, in ?
    main()
  File "/usr/sbin/rhn_register", line 214, in main
    tui.main()
  File "/usr/share/rhn/register/tui.py", line 1042, in main
    tui.run()
  File "/usr/share/rhn/register/tui.py", line 986, in run
    win = self.windows[index](self.screen, self)
  File "/usr/share/rhn/register/tui.py", line 567, in __init__
    tui.hardware = hardware.Hardware()
  File "/usr/share/rhn/register/hardware.py", line 374, in Hardware
    ret = read_network()
  File "/usr/share/rhn/register/hardware.py", line 296, in 
read_network
    hostname, ipaddr = findHostByRoute()
  File "/usr/share/rhn/register/hardware.py", line 276, in 
findHostByRoute
    hostname = socket.gethostbyaddr(intf)[0]
socket.error: host not found

This occurs right after I input my rhn account information.
If I am running the Gnome client, I get past the login screen and the 
next screen shows errors for all options (OS, Version, etc).

Version-Release number of selected component (if applicable):
rhnlib-1.3-11.152
rhn_register-gnome-2.9.2-1.2.1AS
rhn_register-2.9.2-1.2.1AS
up2date-gnome-2.9.3-2.2.1AS
up2date-2.9.3-2.2.1AS

Installed from RHAS2.1 Update 3 iso's
How reproducible:
running rhn_register from console or gnome

Steps to Reproduce:
1.run rhn_register
2.accept license agreement
3.enter account information
4.click next 
  
Actual results:
Traceback (innermost last):
  File "/usr/sbin/rhn_register", line 233, in ?
    main()
  File "/usr/sbin/rhn_register", line 214, in main
    tui.main()
  File "/usr/share/rhn/register/tui.py", line 1042, in main
    tui.run()
  File "/usr/share/rhn/register/tui.py", line 986, in run
    win = self.windows[index](self.screen, self)
  File "/usr/share/rhn/register/tui.py", line 567, in __init__
    tui.hardware = hardware.Hardware()
  File "/usr/share/rhn/register/hardware.py", line 374, in Hardware
    ret = read_network()
  File "/usr/share/rhn/register/hardware.py", line 296, in 
read_network
    hostname, ipaddr = findHostByRoute()
  File "/usr/share/rhn/register/hardware.py", line 276, in 
findHostByRoute
    hostname = socket.gethostbyaddr(intf)[0]
socket.error: host not found

Expected results:


Additional info:
Comment 1 Suzanne Hillman 2004-02-10 17:02:19 EST

*** This bug has been marked as a duplicate of 113599 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:01:04 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.