Bug 1149278 - partx fails to update a specific partition other than the first
Summary: partx fails to update a specific partition other than the first
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: util-linux
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Karel Zak
QA Contact: Tomas Dolezal
URL:
Whiteboard:
: 1163426 (view as bug list)
Depends On:
Blocks: 1162228
TreeView+ depends on / blocked
 
Reported: 2014-10-03 16:02 UTC by Andy Grimm
Modified: 2016-11-08 03:47 UTC (History)
7 users (show)

Fixed In Version: util-linux-2.23.2-18.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-03-05 13:18:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1244662 0 None None None Never
Red Hat Product Errata RHBA-2015:0501 0 normal SHIPPED_LIVE util-linux bug fix and enhancement update 2015-03-05 16:20:51 UTC

Description Andy Grimm 2014-10-03 16:02:19 UTC
Description of problem:

A command like "partx -u 2 /dev/vda" will always fail due to some incorrect logic in upd_parts.

Version-Release number of selected component (if applicable):

util-linux-2.23.2-16.el7.x86_64

How reproducible:

Always

Steps to Reproduce:
1. Boot a system with a disk with 2 or more partitions on a disk (which are in use).
2. Run "partx -v -u <partno> <device>" where <partno> is any valid partition number other than 1, and <device> is the disk device

Actual results:

partition: 2, disk: /dev/vda, lower: 2, upper: 2
/dev/vda: partition table type 'dos' detected
partx: /dev/vda: updating partition #2 failed: Device or resource busy
partx: /dev/vda: error updating partition 2

Expected results:

partition: 2, disk: /dev/vda, lower: 2, upper: 2
/dev/vda: partition table type 'dos' detected
/dev/vda: partition #2 resized

Additional info:

Launchpad bug:  https://bugs.launchpad.net/ubuntu/+source/util-linux/+bug/1244662
Patch: http://article.gmane.org/gmane.linux.utilities.util-linux-ng/8385

I have not tested building with the patch yet, but I have confirmed that in Fedora 21, where util-linux is new enough to contain the above fix, the issue is not present.

Comment 7 Colin Walters 2014-10-17 03:37:18 UTC
This has been pulled into the Atomic 1.0 override: https://brewweb.devel.redhat.com/taginfo?tagID=6363

Comment 8 Karel Zak 2014-11-18 10:22:14 UTC
*** Bug 1163426 has been marked as a duplicate of this bug. ***

Comment 11 errata-xmlrpc 2015-03-05 13:18:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0501.html

Comment 12 Irving Popovetsky 2015-03-06 22:56:10 UTC
Question: Is there an equivalent bug report open for RHEL6?   It suffers from the same issue and I'd love to see that fixed as well.


Note You need to log in before you can comment on or make changes to this bug.