Bug 1149335 - gtk3-3.14.1 - irregular appearance - nm-applet systray icons menu
Summary: gtk3-3.14.1 - irregular appearance - nm-applet systray icons menu
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gtk3
Version: 21
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1160219 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-03 18:25 UTC by poma
Modified: 2014-11-15 09:11 UTC (History)
9 users (show)

Fixed In Version: aisleriot-3.14.2-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-15 09:11:41 UTC


Attachments (Terms of Use)
dirty workaround patch (1.29 KB, patch)
2014-10-27 23:45 UTC, Michael Krause
no flags Details | Diff
This reverts gtk+ git commit 6b7b55f (2.90 KB, patch)
2014-10-31 20:20 UTC, poma
no flags Details | Diff

Description poma 2014-10-03 18:25:04 UTC
Left click on the icon - menu doesn't stay open, must hold down the left mice button.

Comment 1 poma 2014-10-03 18:31:44 UTC
- gtk3-3.14.1 - irregular appearance - firewall-applet systray icons menu
  https://bugzilla.redhat.com/show_bug.cgi?id=1149334

Comment 2 Jirka Klimes 2014-10-03 20:22:56 UTC
This is most probably GTK issue. I can see it as well together with bug 1112650.

Comment 3 Jiri Popelka 2014-10-06 08:51:26 UTC
*** Bug 1149334 has been marked as a duplicate of this bug. ***

Comment 4 Robby Workman 2014-10-22 05:44:54 UTC
Still present in 3.14.4

Comment 5 Michael Krause 2014-10-27 23:44:25 UTC
Attachaed a workaround for this issue.
Basically use button-press-event instead of activate signal in setup_widgets().
Note that I have no clue what I'm doing :)

Comment 6 Michael Krause 2014-10-27 23:45:24 UTC
Created attachment 951196 [details]
dirty workaround patch

Comment 7 poma 2014-10-31 20:20:55 UTC
Created attachment 952588 [details]
This reverts gtk+ git commit 6b7b55f


gtkwindow: run ::event and specific handlers for EWMH action triggering events
https://git.gnome.org/browse/gtk+/commit/?id=6b7b55

commit 6b7b55f9b2b9eb7e05f68e932f9c804cb7ada412
Author: Carlos Garnacho <carlosg@gnome.org>
Date:   Tue Sep 16 21:19:40 2014 +0200

    gtkwindow: run ::event and specific handlers for EWMH action triggering events
    
    This gives an opportunity for implementations to handle these events
    differently, instead of hardcoding the WM-triggering behavior.
    
    gtk_window_event() only forwards events for WM management if the event
    widget is not the window (ie. caught when bubbling), so is safe to be
    called here without triggering gtk_window_handle_wm_event() twice.
    
    This commit is an adaption to master of
    https://bugzilla.gnome.org/show_bug.cgi?id=736702#c1 by Cosimo Cecchi.

Comment 8 Wolfgang Ulbrich 2014-11-01 11:16:19 UTC
This affects also Mate desktop, btw. users who runs gnome applications in another desktop.

Comment 9 Matthias Clasen 2014-11-03 15:23:00 UTC
Why would we be reverting upstream patches in the Fedora package, instead of figuring out what the actual issue is ?

Comment 10 Matthias Clasen 2014-11-03 18:10:36 UTC
why did you do that ?

Comment 11 Wolfgang Ulbrich 2014-11-03 22:24:53 UTC
Thank you for re-open Matthias.
A lot of people will run into this issue in when f21 is released.
I did a test in a Mate GTK3 enviroment, the issue still exists here too.

Comment 12 Wolfgang Ulbrich 2014-11-04 02:21:41 UTC
sorry, i don't see that the issue is fixed.
Please let us know why you think like this?

Comment 13 poma 2014-11-04 05:25:06 UTC
When you fix this mess upstream, announce it here.
Until then ...

Comment 14 Wolfgang Ulbrich 2014-11-04 11:15:19 UTC

*** This bug has been marked as a duplicate of bug 1160219 ***

Comment 15 Carlos Garnacho 2014-11-04 19:26:26 UTC
There is now a proper fix for this in the upstream 3.14/master branches. I'm unsure whether to set another bug state just to get it WORKSFORMEd yet again...

Comment 16 poma 2014-11-05 05:11:27 UTC
Tested, this commit fixed the problem
gtkwindow: Resort to regular event bubbling by all means on non-toplevels
https://git.gnome.org/browse/gtk+/commit/?id=d9a433d

Comment 17 poma 2014-11-05 05:14:07 UTC
Kalev, please push this downstreet and close when you're finished.

Comment 18 Kalev Lember 2014-11-05 10:58:20 UTC
This fix is going to be in a new upstream release next week and we'll do Fedora builds then as well.

Comment 19 poma 2014-11-10 16:16:32 UTC
(In reply to Kalev Lember from comment #18)
> This fix is going to be in a new upstream release next week and we'll do
> Fedora builds then as well.

Thanks man, 
the eagle has landed.

Comment 20 Wolfgang Ulbrich 2014-11-10 21:18:07 UTC
*** Bug 1160219 has been marked as a duplicate of this bug. ***

Comment 21 Fedora Update System 2014-11-12 22:18:43 UTC
aisleriot-3.14.2-1.fc21,appstream-data-21-16.fc21,at-spi2-core-2.14.1-1.fc21,bijiben-3.14.2-1.fc21,cheese-3.14.2-1.fc21,control-center-3.14.2-1.fc21,eog-3.14.2-2.fc21,eog-plugins-3.14.1-1.fc21,epiphany-3.14.2-1.fc21,file-roller-3.14.2-1.fc21,four-in-a-row-3.14.2-1.fc21,gedit-3.14.1-1.fc21,gedit-plugins-3.14.1-1.fc21,glib2-2.42.1-1.fc21,gnome-boxes-3.14.2-1.fc21,gnome-chess-3.14.1-1.fc21,gnome-color-manager-3.14.2-1.fc21,gnome-contacts-3.14.2-1.fc21,gnome-desktop3-3.14.2-1.fc21,gnome-devel-docs-3.14.2-1.fc21,gnome-dictionary-3.14.2-1.fc21,gnome-disk-utility-3.14.0-1.fc21,gnome-klotski-3.14.2-1.fc21,gnome-logs-3.14.2-1.fc21,gnome-maps-3.14.2-1.fc21,gnome-music-3.14.2-1.fc21,gnome-online-accounts-3.14.2-1.fc21,gnome-packagekit-3.14.2-1.fc21,gnome-photos-3.14.2-1.fc21,gnome-robots-3.14.2-1.fc21,gnome-settings-daemon-3.14.2-1.fc21,gnome-shell-3.14.2-1.fc21,gnome-shell-extensions-3.14.2-1.fc21,gnome-software-3.14.2-2.fc21,gnome-sound-recorder-3.14.2-1.fc21,gnome-sudoku-3.14.2-1.fc21,gnome-terminal-3.14.2-1.fc21,gnome-themes-standard-3.14.2-1.fc21,gnome-user-docs-3.14.2-1.fc21,gtk3-3.14.5-1.fc21,gtksourceview3-3.14.2-1.fc21,gucharmap-3.14.2-1.fc21,gvfs-1.22.2-1.fc21,iagno-3.14.2-1.fc21,libappstream-glib-0.2.7-1.fc21,libgdata-0.16.1-1.fc21,mutter-3.14.2-1.fc21,orca-3.14.2-1.fc21,vinagre-3.14.2-1.fc21,vino-3.14.1-1.fc21,vte291-0.38.2-1.fc21,webkitgtk4-2.6.3-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/aisleriot-3.14.2-1.fc21,appstream-data-21-16.fc21,at-spi2-core-2.14.1-1.fc21,bijiben-3.14.2-1.fc21,cheese-3.14.2-1.fc21,control-center-3.14.2-1.fc21,eog-3.14.2-2.fc21,eog-plugins-3.14.1-1.fc21,epiphany-3.14.2-1.fc21,file-roller-3.14.2-1.fc21,four-in-a-row-3.14.2-1.fc21,gedit-3.14.1-1.fc21,gedit-plugins-3.14.1-1.fc21,glib2-2.42.1-1.fc21,gnome-boxes-3.14.2-1.fc21,gnome-chess-3.14.1-1.fc21,gnome-color-manager-3.14.2-1.fc21,gnome-contacts-3.14.2-1.fc21,gnome-desktop3-3.14.2-1.fc21,gnome-devel-docs-3.14.2-1.fc21,gnome-dictionary-3.14.2-1.fc21,gnome-disk-utility-3.14.0-1.fc21,gnome-klotski-3.14.2-1.fc21,gnome-logs-3.14.2-1.fc21,gnome-maps-3.14.2-1.fc21,gnome-music-3.14.2-1.fc21,gnome-online-accounts-3.14.2-1.fc21,gnome-packagekit-3.14.2-1.fc21,gnome-photos-3.14.2-1.fc21,gnome-robots-3.14.2-1.fc21,gnome-settings-daemon-3.14.2-1.fc21,gnome-shell-3.14.2-1.fc21,gnome-shell-extensions-3.14.2-1.fc21,gnome-software-3.14.2-2.fc21,gnome-sound-recorder-3.14.2-1.fc21,gnome-sudoku-3.14.2-1.fc21,gnome-terminal-3.14.2-1.fc21,gnome-themes-standard-3.14.2-1.fc21,gnome-user-docs-3.14.2-1.fc21,gtk3-3.14.5-1.fc21,gtksourceview3-3.14.2-1.fc21,gucharmap-3.14.2-1.fc21,gvfs-1.22.2-1.fc21,iagno-3.14.2-1.fc21,libappstream-glib-0.2.7-1.fc21,libgdata-0.16.1-1.fc21,mutter-3.14.2-1.fc21,orca-3.14.2-1.fc21,vinagre-3.14.2-1.fc21,vino-3.14.1-1.fc21,vte291-0.38.2-1.fc21,webkitgtk4-2.6.3-1.fc21

Comment 22 Fedora Update System 2014-11-13 18:06:29 UTC
Package aisleriot-3.14.2-1.fc21, appstream-data-21-16.fc21, at-spi2-core-2.14.1-1.fc21, bijiben-3.14.2-1.fc21, cheese-3.14.2-1.fc21, control-center-3.14.2-1.fc21, eog-3.14.2-2.fc21, eog-plugins-3.14.1-1.fc21, epiphany-3.14.2-1.fc21, file-roller-3.14.2-1.fc21, four-in-a-row-3.14.2-1.fc21, gedit-3.14.1-1.fc21, gedit-plugins-3.14.1-1.fc21, glib2-2.42.1-1.fc21, gnome-boxes-3.14.2-1.fc21, gnome-chess-3.14.1-1.fc21, gnome-color-manager-3.14.2-1.fc21, gnome-contacts-3.14.2-1.fc21, gnome-desktop3-3.14.2-1.fc21, gnome-devel-docs-3.14.2-1.fc21, gnome-dictionary-3.14.2-1.fc21, gnome-disk-utility-3.14.0-1.fc21, gnome-klotski-3.14.2-1.fc21, gnome-logs-3.14.2-1.fc21, gnome-maps-3.14.2-1.fc21, gnome-music-3.14.2-1.fc21, gnome-online-accounts-3.14.2-1.fc21, gnome-packagekit-3.14.2-1.fc21, gnome-photos-3.14.2-1.fc21, gnome-robots-3.14.2-1.fc21, gnome-settings-daemon-3.14.2-1.fc21, gnome-shell-3.14.2-1.fc21, gnome-shell-extensions-3.14.2-1.fc21, gnome-software-3.14.2-2.fc21, gnome-sound-recorder-3.14.2-1.fc21, gnome-sudoku-3.14.2-1.fc21, gnome-terminal-3.14.2-1.fc21, gnome-themes-standard-3.14.2-1.fc21, gnome-user-docs-3.14.2-1.fc21, gtk3-3.14.5-1.fc21, gtksourceview3-3.14.2-1.fc21, gucharmap-3.14.2-1.fc21, gvfs-1.22.2-1.fc21, iagno-3.14.2-1.fc21, libappstream-glib-0.2.7-1.fc21, libgdata-0.16.1-1.fc21, mutter-3.14.2-1.fc21, orca-3.14.2-1.fc21, vinagre-3.14.2-1.fc21, vino-3.14.1-1.fc21, vte291-0.38.2-1.fc21, webkitgtk4-2.6.3-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing aisleriot-3.14.2-1.fc21 appstream-data-21-16.fc21 at-spi2-core-2.14.1-1.fc21 bijiben-3.14.2-1.fc21 cheese-3.14.2-1.fc21 control-center-3.14.2-1.fc21 eog-3.14.2-2.fc21 eog-plugins-3.14.1-1.fc21 epiphany-3.14.2-1.fc21 file-roller-3.14.2-1.fc21 four-in-a-row-3.14.2-1.fc21 gedit-3.14.1-1.fc21 gedit-plugins-3.14.1-1.fc21 glib2-2.42.1-1.fc21 gnome-boxes-3.14.2-1.fc21 gnome-chess-3.14.1-1.fc21 gnome-color-manager-3.14.2-1.fc21 gnome-contacts-3.14.2-1.fc21 gnome-desktop3-3.14.2-1.fc21 gnome-devel-docs-3.14.2-1.fc21 gnome-dictionary-3.14.2-1.fc21 gnome-disk-utility-3.14.0-1.fc21 gnome-klotski-3.14.2-1.fc21 gnome-logs-3.14.2-1.fc21 gnome-maps-3.14.2-1.fc21 gnome-music-3.14.2-1.fc21 gnome-online-accounts-3.14.2-1.fc21 gnome-packagekit-3.14.2-1.fc21 gnome-photos-3.14.2-1.fc21 gnome-robots-3.14.2-1.fc21 gnome-settings-daemon-3.14.2-1.fc21 gnome-shell-3.14.2-1.fc21 gnome-shell-extensions-3.14.2-1.fc21 gnome-software-3.14.2-2.fc21 gnome-sound-recorder-3.14.2-1.fc21 gnome-sudoku-3.14.2-1.fc21 gnome-terminal-3.14.2-1.fc21 gnome-themes-standard-3.14.2-1.fc21 gnome-user-docs-3.14.2-1.fc21 gtk3-3.14.5-1.fc21 gtksourceview3-3.14.2-1.fc21 gucharmap-3.14.2-1.fc21 gvfs-1.22.2-1.fc21 iagno-3.14.2-1.fc21 libappstream-glib-0.2.7-1.fc21 libgdata-0.16.1-1.fc21 mutter-3.14.2-1.fc21 orca-3.14.2-1.fc21 vinagre-3.14.2-1.fc21 vino-3.14.1-1.fc21 vte291-0.38.2-1.fc21 webkitgtk4-2.6.3-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-14803/aisleriot-3.14.2-1.fc21,appstream-data-21-16.fc21,at-spi2-core-2.14.1-1.fc21,bijiben-3.14.2-1.fc21,cheese-3.14.2-1.fc21,control-center-3.14.2-1.fc21,eog-3.14.2-2.fc21,eog-plugins-3.14.1-1.fc21,epiphany-3.14.2-1.fc21,file-roller-3.14.2-1.fc21,four-in-a-row-3.14.2-1.fc21,gedit-3.14.1-1.fc21,gedit-plugins-3.14.1-1.fc21,glib2-2.42.1-1.fc21,gnome-boxes-3.14.2-1.fc21,gnome-chess-3.14.1-1.fc21,gnome-color-manager-3.14.2-1.fc21,gnome-contacts-3.14.2-1.fc21,gnome-desktop3-3.14.2-1.fc21,gnome-devel-docs-3.14.2-1.fc21,gnome-dictionary-3.14.2-1.fc21,gnome-disk-utility-3.14.0-1.fc21,gnome-klotski-3.14.2-1.fc21,gnome-logs-3.14.2-1.fc21,gnome-maps-3.14.2-1.fc21,gnome-music-3.14.2-1.fc21,gnome-online-accounts-3.14.2-1.fc21,gnome-packagekit-3.14.2-1.fc21,gnome-photos-3.14.2-1.fc21,gnome-robots-3.14.2-1.fc21,gnome-settings-daemon-3.14.2-1.fc21,gnome-shell-3.14.2-1.fc21,gnome-shell-extensions-3.14.2-1.fc21,gnome-software-3.14.2-2.fc21,gnome-sound-recorder-3.14.2-1.fc21,gnome-sudoku-3.14.2-1.fc21,gnome-terminal-3.14.2-1.fc21,gnome-themes-standard-3.14.2-1.fc21,gnome-user-docs-3.14.2-1.fc21,gtk3-3.14.5-1.fc21,gtksourceview3-3.14.2-1.fc21,gucharmap-3.14.2-1.fc21,gvfs-1.22.2-1.fc21,iagno-3.14.2-1.fc21,libappstream-glib-0.2.7-1.fc21,libgdata-0.16.1-1.fc21,mutter-3.14.2-1.fc21,orca-3.14.2-1.fc21,vinagre-3.14.2-1.fc21,vino-3.14.1-1.fc21,vte291-0.38.2-1.fc21,webkitgtk4-2.6.3-1.fc21
then log in and leave karma (feedback).

Comment 23 Fedora Update System 2014-11-15 09:11:41 UTC
aisleriot-3.14.2-1.fc21, appstream-data-21-16.fc21, at-spi2-core-2.14.1-1.fc21, bijiben-3.14.2-1.fc21, cheese-3.14.2-1.fc21, control-center-3.14.2-1.fc21, eog-3.14.2-2.fc21, eog-plugins-3.14.1-1.fc21, epiphany-3.14.2-1.fc21, file-roller-3.14.2-1.fc21, four-in-a-row-3.14.2-1.fc21, gedit-3.14.1-1.fc21, gedit-plugins-3.14.1-1.fc21, glib2-2.42.1-1.fc21, gnome-boxes-3.14.2-1.fc21, gnome-chess-3.14.1-1.fc21, gnome-color-manager-3.14.2-1.fc21, gnome-contacts-3.14.2-1.fc21, gnome-desktop3-3.14.2-1.fc21, gnome-devel-docs-3.14.2-1.fc21, gnome-dictionary-3.14.2-1.fc21, gnome-disk-utility-3.14.0-1.fc21, gnome-klotski-3.14.2-1.fc21, gnome-logs-3.14.2-1.fc21, gnome-maps-3.14.2-1.fc21, gnome-music-3.14.2-1.fc21, gnome-online-accounts-3.14.2-1.fc21, gnome-packagekit-3.14.2-1.fc21, gnome-photos-3.14.2-1.fc21, gnome-robots-3.14.2-1.fc21, gnome-settings-daemon-3.14.2-1.fc21, gnome-shell-3.14.2-1.fc21, gnome-shell-extensions-3.14.2-1.fc21, gnome-software-3.14.2-2.fc21, gnome-sound-recorder-3.14.2-1.fc21, gnome-sudoku-3.14.2-1.fc21, gnome-terminal-3.14.2-1.fc21, gnome-themes-standard-3.14.2-1.fc21, gnome-user-docs-3.14.2-1.fc21, gtk3-3.14.5-1.fc21, gtksourceview3-3.14.2-1.fc21, gucharmap-3.14.2-1.fc21, gvfs-1.22.2-1.fc21, iagno-3.14.2-1.fc21, libappstream-glib-0.2.7-1.fc21, libgdata-0.16.1-1.fc21, mutter-3.14.2-1.fc21, orca-3.14.2-1.fc21, vinagre-3.14.2-1.fc21, vino-3.14.1-1.fc21, vte291-0.38.2-1.fc21, webkitgtk4-2.6.3-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.