Bug 1149342 - Metrics Throughput can increase multiple times for the same node
Summary: Metrics Throughput can increase multiple times for the same node
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Core Server, Storage Node
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ER05
: JON 3.3.0
Assignee: Michael Burman
QA Contact: Armine Hovsepyan
URL:
Whiteboard:
Depends On: 1126209
Blocks: 1100309 1133605 1098243
TreeView+ depends on / blocked
 
Reported: 2014-10-03 19:04 UTC by Michael Burman
Modified: 2015-09-03 00:03 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1126209
Environment:
Last Closed: 2014-12-11 14:00:24 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1157730 None None None Never

Internal Links: 1157730

Description Michael Burman 2014-10-03 19:04:41 UTC
+++ This bug was initially created as a clone of Bug #1126209 +++

Description of problem:

15:40:27,367 INFO  [org.rhq.server.metrics.StorageSession] (Cassandra Java Driver worker-12) /17.176.208.118 is up
15:40:27,367 INFO  [org.rhq.server.metrics.StorageSession] (Cassandra Java Driver worker-12) Changing request throughput from 30000.0 request/sec to 40000.0 requests/sec
15:40:27,367 INFO  [org.rhq.enterprise.server.storage.StorageClusterMonitor] (Cassandra Java Driver worker-12) Storage cluster is up
15:40:27,368 INFO  [org.rhq.enterprise.server.storage.StorageClusterMonitor] (Cassandra Java Driver worker-12) Storage node at 17.176.208.118 is up
15:40:28,096 INFO  [org.rhq.server.metrics.StorageSession] (Cassandra Java Driver worker-13) /17.176.208.118 is up
15:40:28,096 INFO  [org.rhq.server.metrics.StorageSession] (Cassandra Java Driver worker-13) Changing request throughput from 40000.0 request/sec to 50000.0 requests/sec
15:40:28,096 INFO  [org.rhq.enterprise.server.storage.StorageClusterMonitor] (Cassandra Java Driver worker-13) Storage node at 17.176.208.118 is up

Seems like a race condition... The rate should be 30000 not go up to 50000


Version-Release number of selected component (if applicable): 4.12


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from John Sanda on 2014-08-25 10:37:13 EDT ---

I am marking this as a blocker for bug 1100309 which is the BZ against which the throttling work is being tracked.

Comment 1 Michael Burman 2014-10-10 06:02:09 UTC
Fixed in the same commit as BZ 1098243 (in master):

commit 57c72fd8254998281c157852d0f3bf3e363c09a6
Author: Michael Burman <miburman@redhat.com>
Date:   Tue Oct 7 12:36:50 2014 +0300

    [BZ 1098243] [BZ 1149342] When encountering a timeout on StorageSession, recreate RateLimiter with higher warmup time.

Comment 2 Libor Zoubek 2014-10-13 09:11:12 UTC
branch:  release/jon3.3.x
link:    https://github.com/rhq-project/rhq/commit/b0031db67
time:    2014-10-13 11:10:26 +0200
commit:  b0031db6702b26520b92fb30b83774dcb53f86fb
author:  Michael Burman - miburman@redhat.com
message: [BZ 1098243] [BZ 1149342] When encountering a timeout on StorageSession,
         recreate RateLimiter with higher warmup time.
         (cherry picked from commit
         57c72fd8254998281c157852d0f3bf3e363c09a6) Signed-off-by: Libor
         Zoubek <lzoubek@redhat.com>

Comment 3 Simeon Pinder 2014-10-21 20:24:29 UTC
Moving to ON_QA as available to test with the latest brew build:
https://brewweb.devel.redhat.com//buildinfo?buildID=394734

Comment 4 Armine Hovsepyan 2014-10-27 15:12:22 UTC
unable to reproduce the issue  - marking as verified
related BZ #1157730 filed


Note You need to log in before you can comment on or make changes to this bug.