Bug 1149449 - [RFE] Add Import VM functionality in more prominent location such as under the Virtual Machines tab
Summary: [RFE] Add Import VM functionality in more prominent location such as under th...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Allon Mureinik
QA Contact: Kevin Alon Goldblatt
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-05 10:12 UTC by Gilad Lazarovich
Modified: 2016-03-09 20:40 UTC (History)
11 users (show)

Fixed In Version: ovirt-engine-3.6.0_qa1
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 20:40:45 UTC
oVirt Team: Storage
Target Upstream Version:
sherold: Triaged+


Attachments (Terms of Use)
Import VM (82.37 KB, image/png)
2015-01-27 23:53 UTC, Einav Cohen
no flags Details
VM import options on the NFS export domain and the options under the Virtual Machines tab (224.56 KB, application/x-gzip)
2015-02-03 17:25 UTC, Gilad Lazarovich
no flags Details
Screenshots (198.35 KB, image/png)
2015-05-04 11:22 UTC, Kevin Alon Goldblatt
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC

Description Gilad Lazarovich 2014-10-05 10:12:13 UTC
Add Import VM functionality in more prominent location such as under the Virtual Machines tab.  Currently, in order to Import a VM, the end user has to go through the Storage tab, then click on an Export domain, now click on the VM Import tab and then on the Import button

Version-Release number of selected component (if applicable):
3.5 vt4

How reproducible:
100%

Comment 1 Allon Mureinik 2015-01-27 23:17:47 UTC
Einav, your two cents on this?

Comment 2 Einav Cohen 2015-01-27 23:53:05 UTC
Created attachment 984920 [details]
Import VM

Comment 3 Einav Cohen 2015-01-27 23:55:27 UTC
(In reply to Allon Mureinik from comment #1)
> Einav, your two cents on this?

I was under the impression that we already have an Import VM functionality from within the VMs main tab (see attachment 984920 [details] to see the Import VM availability from the Storage main tab, as mentioned in Comment #0, as well as from the VMs main tab, as requested in Comment #0). 

@Allon/Gilad - am I missing something?

Comment 4 Gilad Lazarovich 2015-02-03 17:25:58 UTC
Created attachment 987699 [details]
VM import options on the NFS export domain and the options under the Virtual Machines tab

Comment 5 Einav Cohen 2015-02-03 17:45:56 UTC
Thanks, Gilad.

@Allon - the option to Import a VM via the VMs main tab seems to be included in oVirt master (3.6) (attachment 984920 [details]) but not in RHEV 3.5 (attachment 987699 [details]) - does this feature exists only in 3.6 (if so - BZ should probably move to MODIFIED)? Only in upstream (if so - why isn't it in downstream)? thanks.

Comment 6 Allon Mureinik 2015-02-05 12:24:11 UTC
True - this was done, recently, in oVirt Engine upstream master (http://gerrit.ovirt.org/#/c/29381/).
Moving to MODIFIED, as, like Einav stated, this is fixed for 3.6.

Comment 7 Kevin Alon Goldblatt 2015-05-04 11:22:07 UTC
Created attachment 1021668 [details]
Screenshots

Added screenshots

Comment 8 Kevin Alon Goldblatt 2015-05-04 11:22:45 UTC
Verified with version:
------------------------
v3.6
ovirt-engine-3.6.0-0.0.master.20150412172306.git55ba764.el6.noarch
vdsm-4.17.0-632.git19a83a2.el7.x86_64

Verified using the following scenario:
---------------------------------------
Steps to reproduce:

1. Via the VM tab in the Web Admin > Find the Import option > The option is now available and when pressed opens up the Import VM dialog.


Adding screenshots of the Import option which is now available in the VM tab

Moving to Verified!

Comment 11 errata-xmlrpc 2016-03-09 20:40:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.