Bug 1149469 - [SWT] Eclipse window not repainted after closing marketplace window
Summary: [SWT] Eclipse window not repainted after closing marketplace window
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Roland Grunberg
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-05 11:31 UTC by Christian Stadelmann
Modified: 2014-10-14 04:32 UTC (History)
9 users (show)

Fixed In Version: eclipse-mpc-1.3.1-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-14 04:32:03 UTC
Type: Bug


Attachments (Terms of Use)
eclipse exported log file (6.00 KB, text/plain)
2014-10-05 11:31 UTC, Christian Stadelmann
no flags Details

Description Christian Stadelmann 2014-10-05 11:31:31 UTC
Created attachment 944015 [details]
eclipse exported log file

Version-Release number of selected component (if applicable):
eclipse-avr.noarch                       2.3.4-9.fc21
eclipse-cdt.x86_64                       1:8.4.0-5.fc21
eclipse-cdt-parsers.x86_64               1:8.4.0-5.fc21
eclipse-changelog.noarch                 2:3.1.0-2.fc21
eclipse-checkstyle.noarch                5.6.1-2.fc21
eclipse-dltk.noarch                      5.1.0-2.fc21
eclipse-ecf-core.noarch                  3.9.0-1.fc21
eclipse-egit.noarch                      3.5.0-1.fc21
eclipse-emf.noarch                       2.10.1-1.fc21
eclipse-emf-core.noarch                  1:2.10.1-1.fc21
eclipse-equinox-osgi.x86_64              1:4.4.1-3.fc21
eclipse-findbugs.noarch                  3.0.0-1.fc21
eclipse-jdt.x86_64                       1:4.4.1-3.fc21
eclipse-jgit.noarch                      3.5.0-1.fc21
eclipse-linuxtools.noarch                3.1.0-2.fc21
eclipse-manpage.noarch                   3.1.0-2.fc21
eclipse-mpc.noarch                       1.3.0-1.fc21
eclipse-p2-discovery.x86_64              1:4.4.1-3.fc21
eclipse-packagekit.noarch                0.1.0-7.fc21
eclipse-pde.x86_64                       1:4.4.1-3.fc21
eclipse-platform.x86_64                  1:4.4.1-3.fc21
eclipse-ptp.x86_64                       8.0.1-1.fc21
eclipse-ptp-rdt.noarch                   8.0.1-1.fc21
eclipse-ptp-rdt-xlc.noarch               8.0.1-1.fc21
eclipse-pydev.noarch                     1:3.7.1-1.fc21
eclipse-remote.noarch                    1.1.0-1.fc21
eclipse-rse.noarch                       3.6.0-1.fc21
eclipse-shelled.noarch                   2.0.3-4.fc21
eclipse-subclipse.noarch                 1.10.5-1.fc21
eclipse-swt.x86_64                       1:4.4.1-3.fc21
eclipse-valgrind.noarch                  3.1.0-2.fc21

How reproducible:
Always for my configuration, using different workspaces including a newly created one.

Steps to Reproduce:
1. start eclipse, choose any workspace
2. open the marketplace client from help menu
3. close the marketplace client

Actual results:
Eclipse UI doesn't get repaint any more. Menus are empty (only shadows are visible). Clicking somewhere may trigger actions but you won't see the result until you restart eclipse.

Expected results:
Closing the marketplace client should not make eclipse go strange.

Additional info:
I think the reason might be that the eclipse auto-updater installed another version of MPC client so there are two of them. See attached logfiles exported from eclipse.

Comment 1 Roland Grunberg 2014-10-06 14:30:48 UTC
Looks like org.eclipse.mpc.core is not marked as a singleton bundle to prevent having multiple ones (1.3.0, and 1.3.1) installed at once. We could certainly get a fix for this, but should definitely report it upstream as well.

Comment 2 Roland Grunberg 2014-10-06 16:17:37 UTC
Additionally, while fixing the bundle shipped in Fedora to be a singleton, will permit the update to proceed correctly, future updates will fail in the same manner until upstream fixes the issue on their end.

Comment 3 Roland Grunberg 2014-10-06 16:52:09 UTC
Filed upstream at https://bugs.eclipse.org/bugs/show_bug.cgi?id=446071 .

Comment 4 Christian Stadelmann 2014-10-06 21:19:29 UTC
Does the eclipse-pydev package have a similar issue?

Comment 5 Alexander Kurtakov 2014-10-07 08:38:03 UTC
Reassigning to Roland as he is looking into it.

Comment 6 Roland Grunberg 2014-10-07 14:26:12 UTC
Upstream has fixed the issue [1] and I've also patched our version of eclipse-mpc [2] . I'll be backporting to f21.

Regarding Eclipse PyDev : As far as I can see, every single osgi bundle shipped in eclipse-pydev is a singleton. If you're still seeing the same issue described in your logs but this time with pydev, I would attach those logs, or perhaps file a bug against the eclipse-pydev component in Fedora so we can look at it separately.

[1] http://git.eclipse.org/c/mpc/org.eclipse.epp.mpc.git/commit/?id=fda6591a4aa3a789b373b4c080b634db836332b2
[2] http://pkgs.fedoraproject.org/cgit/eclipse-mpc.git/commit/?id=6429dfdd83e277bace9adc9dbec9de70bfe9ddca

Comment 7 Fedora Update System 2014-10-07 16:05:54 UTC
eclipse-mpc-1.3.1-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/eclipse-mpc-1.3.1-1.fc21

Comment 8 Roland Grunberg 2014-10-07 16:10:42 UTC
I've also proposed updating the version of eclipse-mpc in Fedora 21 to 1.3.1 so there shouldn't be a need to use the external update sites. In the future, if for some reason, users wish to get updates externally, things should also work as expected now that the bundle in question is a singleton.

Comment 9 Fedora Update System 2014-10-08 19:10:14 UTC
Package eclipse-mpc-1.3.1-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing eclipse-mpc-1.3.1-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-12403/eclipse-mpc-1.3.1-1.fc21
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2014-10-14 04:32:03 UTC
eclipse-mpc-1.3.1-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.