Bug 114952 - Installer hangs after mkfs
Installer hangs after mkfs
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
s390 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-04 14:49 EST by Aaron Spangler
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-27 14:26:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aaron Spangler 2004-02-04 14:49:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
Anaconda hangs after creating filesystems but before packages are 
created.  It appears to be trying to read the same installer image 
over and over in an endless loop and deadlocks the CPU.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Prepare the VM reader using the kernel & initrd files
2. IPL
3. Enter TCP/IP information as prompted
4. SSH into server as prompted
5. Select either NFS or FTP based install. (Fails on both) Enter 
NFS/FTP info
6. Setup partitions
7. Select packages (doesn't seem to matter)
8. SSH a second connection into server to monitor progress (run top)
9. After filesystems are created, but before packages are loaded, the 
machine eventually stalls at 100% CPU usage.


Actual Results:  Anaconda hangs.

Expected Results:  Anaconda installs rpms.

Additional info:

When using NFS server, the NFS server gets saturated with NFS 
requests from NFS client that is being installed (running anaconda).
It appears to be requesting the same NFS blocks over and over.  If 
the NFS server becomes overwhelmed, the NFS client complains about a 
compression driver not being able to read blocks.
Comment 1 Aaron Spangler 2004-02-04 14:51:11 EST
Platform=s390 (31 bit)
Comment 2 Jeremy Katz 2004-02-04 15:43:51 EST
What version are you trying to install?  How much memory do you have
for your guests?  Can you ssh in again and scp off the /tmp/syslog and
/tmp/anaconda.log and attach them here?
Comment 3 Aaron Spangler 2004-05-27 14:25:55 EDT
Guest memory was set to 64MB.  This was probably the problem.  As a
result we set it to 256MB and later dumped the Taroon beta to use the
RHEL3AS Update 1 installer.

All worked well once we set the memory to 256MB.

I suspect that was the root cause.

Note You need to log in before you can comment on or make changes to this bug.