Bug 114955 - RHEL 2.1 AS kickstart profile points to RHEL 3 AS tree
RHEL 2.1 AS kickstart profile points to RHEL 3 AS tree
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robin Norwood
:
Depends On:
Blocks: rhn310rc
  Show dependency treegraph
 
Reported: 2004-02-04 15:29 EST by Chris Runge
Modified: 2007-08-06 14:57 EDT (History)
2 users (show)

See Also:
Fixed In Version: rhn360
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 11:15:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Runge 2004-02-04 15:29:59 EST
Description of problem:

I've synced 3 channels: RHEL 2.1 AS, RHEL 3 AS, RHEL 3 WS
I've created 3 kickstart profiles, in the following order: RHEL 3 WS,
RHEL 3 AS, and RHEL 2.1 AS

The RHEL 3 WS/AS profiles can be kickstarted. The RHEL 2.1 AS profile,
however, cannot. The kickstart script points to the RHEL 3 AS tree for
some reason. Here's the line from the Kickstart script:

url --url http://rhnsat.vmware/kickstart/dist/ks-rhel-i386-as-3/

Version-Release number of selected component (if applicable):

rhn-satellite-3.0.9-11

How reproducible:

100% thus far. I've deleted and recreated the 2.1 profile several
times and can't fix this.
Comment 1 Dave Johnson 2004-02-04 19:40:32 EST
I've had the exact same problem when trying to kickstart RHEL 2.1 ES
Update 3.  The kickstart script is generated to point to RHEL 3 AS. 
One difference between my environment and Chris', is that I have only
created a kickstart profile for RHEL 2.1 ES, and not RHEL 3 at all.  I
can also reproduce this at will.
Comment 2 Chris Runge 2004-02-04 21:57:59 EST
It looks like I was wrong about the RHEL 3 WS being correct after
all... it works, but afterwards systems have RHEL 3 AS as their base
channel. I looked at the kickstart script and sure enough it points to
RHEL 3 AS.

On a related note, I can't find where on the system the Kickstart
scripts are located to manually override this.
Comment 3 Bret McMillan 2004-02-05 11:06:16 EST
Could it possibly be that the External Location set on this page:
/network/systems/provisioning/trees/edit-tree.pxt

points at a 3AS distribution instead of a 3WS?

Also make sure the kickstart profile being used points to the correct
Distribution:
/network/systems/provisioning/kickstarts/details.pxt
Comment 4 Robin Norwood 2004-02-05 11:22:27 EST
Ok, this is fixed in CVS.  We were re-writing the URL correctly for
scheduled sessions, but not for kickstarts by label.
 
Chris: The kickstart config files are not stored on the filesystem -
they are dynamically generated at the time they're requested.



Note You need to log in before you can comment on or make changes to this bug.