Bug 114969 - tmpwatch does not clean up socket files in /tmp
Summary: tmpwatch does not clean up socket files in /tmp
Status: CLOSED DUPLICATE of bug 66148
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: tmpwatch   
(Show other bugs)
Version: 2.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Miloslav Trmač
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-04 22:58 UTC by C. Ray Ng
Modified: 2007-11-30 22:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:01:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description C. Ray Ng 2004-02-04 22:58:24 UTC
Description of problem:
tmpwatch does not remove socket files, in particular, files in 
/tmp/orbit-*/linc* left by gnome were allowed to grow.

Version-Release number of selected component (if applicable):
tmpwatch-2.8.4-5 (RHEL3, RH9) down to tmpwatch-2.8.3-1 (RH7.3)

How reproducible:
Always

Steps to Reproduce:
1. login via gdm
2. use the system for some period of time
3.
  
Actual results:
socket files accumulated in /tmp/orbit-*/* 

Expected results:
clean up after a while.

Additional info:
Adding --all in /etc/cron.daily/tmpwatch would be a solution, i.e.
/usr/sbin/tmpwatch --all 240 /tmp
/usr/sbin/tmpwatch --all 720 /var/tmp

Comment 1 Miloslav Trmač 2004-08-13 20:54:06 UTC
This is too dangerous.
It could for example remove the sockets used for X11
(atime on the socket is changed only on new connections,
not only on X protocol traffic).

*** This bug has been marked as a duplicate of 66148 ***

Comment 2 C. Ray Ng 2004-08-13 22:45:07 UTC
Right, a safer version that I have been using is the following:

# cleanup accumulated socket files in /tmp/orbit-* first
#
/usr/sbin/tmpwatch --fuser --all 240 /tmp/orbit-*
/usr/sbin/tmpwatch 240 /tmp
/usr/sbin/tmpwatch 720 /var/tmp
...

Comment 3 Miloslav Trmač 2004-08-13 23:04:19 UTC
The rationale from bug 66148 is summarized in comment 1 above.

Comment 4 David Baron 2004-08-14 03:35:42 UTC
FWIW, I've seen filesystems run out of inodes due to this problem.

Comment 5 Red Hat Bugzilla 2006-02-21 19:01:05 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.