Bug 114972 - ethereal depends on libpcap.so.0.6.2
ethereal depends on libpcap.so.0.6.2
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: ethereal (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-04 19:00 EST by Thomas Antony
Modified: 2015-03-04 20:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-05 10:37:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Antony 2004-02-04 19:00:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.6) Gecko/20040116

Description of problem:
ethereal depends on libpcap.so.0.6.2, but it should depend on
libpcap.so.0, which is a symbolic link to version
libpcap-0.7.2-7.1.i386.rpm or higher.
A update for package libpcap-0.7.2-7.1.i386.rpm is not possible with
ethereal and ethereal-gnome is installed.
If only libpcap-0.7.2-7.1.i386.rpm was installed and updated to a
newer version, you can't install ethereal....

Version-Release number of selected component (if applicable):
ethereal-0.9.13-4.1.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1. Install libpcap and ethereal from FC1
2. rpm -Uvh libpcap-newer-version.rpm will fail

or

1. Install libpcap from FC1 and update the package to a newer version
2. Installing ethereal will fail

Additional info:
Comment 1 Phil Knirsch 2004-02-05 10:37:35 EST
The problem is that internally in the past the libpcap ABI has
changed, therefore a pretty exact match between ethereal and libpcap
was always necessary.

As unfortunatelt no combined update has been done for ethereal and
libpcap on FC1 i suggest you simply use the FC2 versions of both,
which is a good idea anyway imho.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.