Bug 1149738 - [RFE]Add possibility to disconnect storage on failure
Summary: [RFE]Add possibility to disconnect storage on failure
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: RFEs
Version: ---
Hardware: x86_64
OS: Unspecified
medium
high vote
Target Milestone: ovirt-4.1.0-alpha
: ---
Assignee: Simone Tiraboschi
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-06 14:36 UTC by Elad
Modified: 2019-04-28 14:11 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Cause: Consequence: Fix: Result:
Clone Of:
Environment:
Last Closed: 2016-06-28 13:53:39 UTC
oVirt Team: Integration
ylavi: ovirt-4.1?
sherold: Triaged+
ylavi: planning_ack+
sbonazzo: devel_ack+
ylavi: testing_ack?


Attachments (Terms of Use)
vdsm and setup logs (679.21 KB, application/x-gzip)
2014-10-06 14:36 UTC, Elad
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 48834 master MERGED packaging: setup: add CLI disconnect-storage option 2017-01-10 20:15:32 UTC

Description Elad 2014-10-06 14:36:44 UTC
Created attachment 944274 [details]
vdsm and setup logs

Description of problem:
Executed hosted-engine deployment using iSCSI storage.
The execution failed because I had an engine VM already running from a previous deployment. As part of rolling back the deployment, the host doesn't disconnect from the iSCSI storage server, it remains connected to the target. 

Version-Release number of selected component (if applicable):
vdsm-4.16.5-2.el7.x86_64
ovirt-hosted-engine-setup-1.2.0-1.el7.noarch


How reproducible:
Always


Steps to Reproduce:
1. Run hosted-engine --deploy while having a VM still running on the host

[ INFO  ] Stage: Programs detection
[ INFO  ] Stage: Environment setup
[ ERROR ] The following VMs has been found: 5d832ee1-e066-4087-bc30-a18faffde6ec
[ ERROR ] Failed to execute stage 'Environment setup': Cannot setup Hosted Engine with other VMs running
[ INFO  ] Stage: Clean up
[ INFO  ] Generating answer file '/etc/ovirt-hosted-engine/answers.conf'
[ INFO  ] Answer file '/etc/ovirt-hosted-engine/answers.conf' has been updated
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination


Actual results:
Host doesn't disconnect its open iSCSI session with the storage server after the deploy failure


[root@green-vdsb ~]# iscsiadm -m session
tcp: [2] 10.35.146.129:3260,1 iqn.2008-05.com.xtremio:001e675b8ee0 (non-flash)


Expected results:
Host should clean its session with the iSCSI target after a deploy failure

Additional info: vdsm and setup logs

Comment 1 Sandro Bonazzola 2014-10-07 12:32:29 UTC
This happens also on NFS, storage is not disconnected on failure for allowing further investigation.
It may be worth to add a question about closing storage connection on failure.

Comment 2 Sandro Bonazzola 2014-10-07 12:33:15 UTC
Maybe this should be an RFE for adding such question.

Comment 3 Doron Fediuck 2014-10-22 08:38:58 UTC
Disconnecting during cleanup may be harmful in some scenarios as you may have
running VMs.

The way to handle it will be to add a flag to the answer file which allows
killing the storage connection.

Comment 4 Yaniv Kaul 2016-03-02 19:13:25 UTC
I see no value in disconnecting, except that you might have connected to the wrong storage / LUN / ...

I'd close-wontfix until we hear of a real life scenario where this is required.

Comment 5 Mike McCune 2016-03-28 23:37:25 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 6 Yaniv Lavi 2016-06-28 13:53:39 UTC
Agree with comment #4. Closing.


Note You need to log in before you can comment on or make changes to this bug.