Bug 114977 - Importing files into config channels fails.
Importing files into config channels fails.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bret McMillan
Fanny Augustin
:
Depends On:
Blocks: rhn310rc
  Show dependency treegraph
 
Reported: 2004-02-04 21:12 EST by Chris Kloiber
Modified: 2007-07-31 10:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-24 16:33:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Kloiber 2004-02-04 21:12:10 EST
Description of problem:

Importing files into sandbox or local config channel fails silently.

Schedule an import of a file or files into the system sandbox or
directly into a config channel. Then run rhn_check locally on the
system (so you don't have to wait 2 hours) "rhn_check -v" responds
with something like:

[root@home root]# rhn_check -v
configfiles.upload (10, ['/etc/hosts', '/etc/resolv.conf',
'/etc/sysconfig/network'])

But nothing gets uploaded (or if it does, the satellite doesn't know it).
Comment 1 Bret McMillan 2004-02-05 10:50:56 EST
Can you verify that rhncfg-actions is installed on the machine?
Comment 2 Chris Kloiber 2004-02-05 21:03:31 EST
[ckloiber@home ckloiber]$ rpm -q rhncfg-actions
rhncfg-actions-1.0-20
[ckloiber@home ckloiber]$
Comment 3 Neal Mackanic 2004-02-13 12:56:20 EST
I have also experienced this problem.  I get an SSL error on the
client, and also logged in the logs/httpd/. 

# /usr/sbin/rhn_check
configfiles.upload (86, ['/etc/hosts/resolv.conf'])
XML-RPC error while talking to
https://roundhill.llnl.gov/CONFIG-MANAGEMENT: [('SSL routines',
'SSL3_GET_SERVER_CERTIFICATE', 'certificate verify failed')]

From the error_log I get:

[Fri Feb 13 09:57:25 2004] [error] mod_ssl: SSL handshake failed
(server roundhill.llnl.gov:443, client 128.115.163.63) (OpenSSL
library error follows)
[Fri Feb 13 09:57:25 2004] [error] OpenSSL: error:14094418:SSL
routines:SSL3_READ_BYTES:tlsv1 alert unknown ca
Comment 4 Greg DeKoenigsberg 2004-02-24 15:55:54 EST
Looks like SSL is failing.  Some questions:

* Do other rhncfg actions succeed where this action fails?
* What version of the satellite -- RC1?
* Output of "rpm -qa | grep rhncfg"?
Comment 5 Bret McMillan 2004-02-24 16:32:31 EST
There was an issue with the original rhncfg rpms when pointed at a
satellite.  This should be addressed with the rhncfg-*-24 packages
that are available from rhn.redhat.com in the various RHN Tools channels.
Comment 6 Bret McMillan 2004-02-24 16:33:23 EST
(reopen this issue if you still have the same problems using the -24 rpms)

Note You need to log in before you can comment on or make changes to this bug.