Bug 114979 - 500 Error - Internal Server Error
500 Error - Internal Server Error
Status: CLOSED DUPLICATE of bug 114577
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Fanny Augustin
:
Depends On:
Blocks: rhn310rc
  Show dependency treegraph
 
Reported: 2004-02-04 21:25 EST by Chris Kloiber
Modified: 2007-07-31 10:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Helpful? email triggered by error (4.61 KB, text/plain)
2004-02-04 22:07 EST, Chris Kloiber
no flags Details

  None (edit)
Description Chris Kloiber 2004-02-04 21:25:39 EST
Description of problem:

From this URL (Manual upload of file into local config channel):

https://qa.ckloiber.com/network/configuration/namespaces/upload_file.pxt?ccid=1

I attempted to upload my /etc/hosts to the config channel owned by
root, group of root, and permissions of 644. As a reward, I got the
dreaded:

500 Error - Internal Server Error

It does not seem that the file uploaded matters, none work.
Comment 1 Chris Runge 2004-02-04 21:59:36 EST
I can confirm this. Creating the file with the web gui also fails with
the same error.
Comment 2 Chris Kloiber 2004-02-04 22:07:15 EST
Created attachment 97481 [details]
Helpful? email triggered by error

I got a bunch of these as I triggered this repeatedly.
Comment 3 Chris Kloiber 2004-02-04 22:11:01 EST
BTW, this should probaby be filed as an additional bug, but the Web
Tracebacks are apparently forging themselves to appear to be coming
from the hosted RHN website. 

Note the From: address in the attachment:

From: Red Hat Network <dev-null@rhn.redhat.com>
Comment 4 Bret McMillan 2004-02-05 11:01:45 EST
peter, did this get fixed already and not make it into the sat tree?

Error message:
  RHN::Exception: DBD::Oracle::st execute failed: ORA-01403: no data found
ORA-01403: no data found
ORA-06512: at "RHNSAT.RHN_CONFREVISION_ACCT_TRIG", line 6
ORA-04088: error during execution of trigger
'RHNSAT.RHN_CONFREVISION_ACCT_TRIG'
ORA-06512: at "RHNSAT.RHN_CONFIG", line 21
ORA-06512: at line 3 (DBD NO_DATA: OCIStmtExecute) [for statement
``DECLARE
BEGIN
  :crid := rhn_config.insert_revision(:revision, :cfid, :ccid, :ciid,
:delim_start, :delim_end);
END;
Comment 5 Peter Jones 2004-02-05 17:34:25 EST

*** This bug has been marked as a duplicate of 114577 ***
Comment 6 Red Hat Bugzilla 2006-02-21 14:01:05 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.