Bug 114983 - rhythmbox is not UTF-8 compliant
rhythmbox is not UTF-8 compliant
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-04 23:31 EST by Alexander Farley
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-13 19:08:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of characters not read correctly (245.83 KB, text/plain)
2004-02-13 03:01 EST, Alexander Farley
no flags Details

  None (edit)
Description Alexander Farley 2004-02-04 23:31:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
Rhythmbox does not seem to be able to render/display foreign
characters. For exampley names and titles with umlauts are represented
by a capitol a and a 1/4 sysmbol.

Version-Release number of selected component (if applicable):
rhythmbox-6.5-1

How reproducible:
Always

Steps to Reproduce:
1.run rhythmbox
2.import any name or title with a non-english letter or symbol.
3.symbol is jumbled.
    

Expected Results:  Rhythmbox would be able to display international
characters like all other GNOME components.

Additional info:
Comment 1 Noa Resare 2004-02-12 19:12:41 EST
I use rhytmbox with swedish locale a lot without any problems and have
just verified rhythmbox-0.6.5-1 to work with swedish chars flawlessly.
(That includes both untagged music with international characters in
their filenames and .ogg files with international characters in the tags)

Could you perhaps specify a bit more how I might reproduce this problem?
Comment 2 Alexander Farley 2004-02-13 03:01:17 EST
Created attachment 97637 [details]
screenshot of characters not read correctly

The name should read Husker Du with umlauds instead of over the u's. The name
is Danish for "Do you remember."
Comment 3 Alexander Farley 2004-02-13 03:02:24 EST
This is an issue that has apparently been discussed on the rhythmbox
mailing list. It has something to do with unicode encoding (UTF-16)???
and the way the id3 information is written. So the rhythmbox people
are aware of the issue, but I thought it might help to have
RedHat/Fedora to lean on them a little bit. This issue is really
cosmetic and should happen rather rarely. I have included a screen
shot of the problem. As it was filed as a cosmetic/enhancement bug I
do not think that it is of great importance to fix. It should only be
fixed if this fix is easy. 
Comment 4 Noa Resare 2004-02-13 03:29:24 EST
Since fedora isn't (to my knowledge) capable of plaing mp3 music and
displaying id3 tags without third party addons and since
internationalized filenames and metadata displays correctly with the
supported music format ogg/vorbis I think this bug should be closed.

However, since this is a test release, chances are that new upstream
versions of components such as rhytmbox will be integrated in the
final fedora release. Fixig problems even in unsupported parts of
components upstream will then be included in fedora.
Comment 5 Alexander Farley 2004-02-13 15:30:48 EST
Your assessment is fair enough. I did not know that ogg/vorbis does
not use id3 tags (as I did not use ogg yet). However, in terms of
Fedora:rhythmbox reading and displaying id3 data, the tags are
produced through Fedora's sound-juicer (albeit using a recompiled
gstreamer to get lame). In line with RedHat/Fedora's policy on mp3's
et al. this bug should be closed. I appologize for my negligence in
remembering which components are kosher and which are not and how the
system fits together.
Comment 6 Noa Resare 2004-02-13 17:16:34 EST
That's totally OK, of course :)

You know you can close bugs you opened yourself? Just select what you
feel like a proper solution (for this one I would say NOTABUG, or
WONTFIX) Under the "Bug changes" headline below.

I suppose keeping the open bug lists of the package maintainers short
is a good idea in all cases :)

Note You need to log in before you can comment on or make changes to this bug.