This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 114986 - Fedora Test Update Tracking: gdm-2.4.4.5-1.2
Fedora Test Update Tracking: gdm-2.4.4.5-1.2
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Mike McLean
:
Depends On:
Blocks: 110315 113154 113995
  Show dependency treegraph
 
Reported: 2004-02-05 00:44 EST by Warren Togami
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-10 23:31:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2004-02-05 00:44:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031110 Firebird/0.7

Description of problem:
---------------------------------------------------------------------
Fedora Test Update Notification
FEDORA-2004-064
2004-02-05
---------------------------------------------------------------------
 
Name        : gdm
Version     : 2.4.4.5
Release     : 1.2
Summary     : The GNOME Display Manager.
Description :
Gdm (the GNOME Display Manager) is a highly configurable
reimplementation of xdm, the X Display Manager. Gdm allows you to log
into your system with the X Window System running and supports running
several different X sessions on your local machine at the same time.
 
---------------------------------------------------------------------
Update Information:
 
This is a bug fix update that resolves these three issues:

Bugzilla #110315 - GDM fails counting of XDMCP maximum sessions
This resolves the issue where XDMCP sessions would fail with 
"Maximum number of open XDMCP sessions reached" due to problems 
with the MaxSession counter.  This problem has been problematic 
especially for the K12LTSP community.  K12LTSP expert
administrators are thus encouraged to thoroughly test this
update in production and report findings to the Bugzilla Tracking 
Report.

Bugzilla #113154 - GDM file descriptor leak
Also fixed by the same patch.

Bugzilla #113995 - GDM Japanese translations missing
Patch contributed by Jens Petersen.

Upgrade Note:
Due to past file format changes, gdm moves your existing gdm.conf
and possibly other gdm configuration files to .rpmsave and replaces it
with a pristine copy.  Normal single desktop users probably do not 
need to  worry about this, but this can be problematic for LTSP or 
VNC  remote  desktop users.  It is recommended that these users review
changes between the .rpmsave and pristine config file, and reconfigure.
The 'gdmsetup' GUI config tool found in System Settings -> Login 
Screen may be useful in configuration of gdm.

Report definite findings to this Test Update Tracking report.
If no regressions are confirmed by February 16th, 2004 then this 
update should become final.

---------------------------------------------------------------------
* Wed Feb 04 2004 Warren Togami <wtogami@redhat.com> 1:2.4.4.5-1.2
- renamed for FC1 update
 
* Tue Feb 03 2004 Warren Togami <wtogami@redhat.com> 1:2.4.4.5-9
- add two lines to match upstream CVS to xdmcp_sessions.patch
  Fully resolves #110315 and #113154
 
* Sun Feb 01 2004 Warren Togami <wtogami@redhat.com> 1:2.4.4.5-8
- patch30 xdmcp_session counter fix from gdm-2.5.90.0 #110315
- automake14 really needed, not automake
- BR libcroco-devel, libcroco-devel, libattr-devel, gettext
- conditionally BR libselinux-devel
- explicit epoch in all deps
- make the ja.po time format change with a sed expression rather than
  overwriting the whole file (Petersen #113995)
 
---------------------------------------------------------------------
This update can be downloaded from:
 
http://download.fedora.redhat.com/pub/fedora/linux/core/updates/testing/1/
 
61f2777a2984d1e6654a5016cd618d10  SRPMS/gdm-2.4.4.5-1.2.src.rpm
5bfc22d7aa5765240a474f4f35c1d3a1  i386/gdm-2.4.4.5-1.2.i386.rpm
57bcd986204d950b86c7865ee9e452b8 
i386/debug/gdm-debuginfo-2.4.4.5-1.2.i386.rpm
 
This update can also be installed with the Update Agent; you can
launch the Update Agent with the 'up2date' command.  You may
need to edit your up2date channels configuration.  Within
/etc/sysconfig/rhn/sources enable the following line:
yum updates-testing http://fedora.redhat.com/updates/testing/fedora-core-1
---------------------------------------------------------------------
Comment 1 Warren Togami 2004-02-10 23:31:09 EST
This update has been published early due to a large amount of positive
responses from k12osn.

Note You need to log in before you can comment on or make changes to this bug.