Bug 114990 - printf-style problems
printf-style problems
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libgnomeprint (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-05 04:50 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-03 11:43:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2004-02-05 04:50:22 EST
Description of problem:

I just tried to compile package libgnomeprint-1.116.0-7 from Redhat
Fedora Core 1.

The compiler said

1.

gp-tt-t1.c(4932): warning #268: the format string ends before this
argument

The source code is

	retval = ttf_printf (retval, &size, &length,
                         "%d %d hstem\n"
                         , g->hstems[i].value, g->hstems[i + 1].value
                         , g->hstems[i + 1].value - g->hstems[i].value);

Two %d specifiers, but three parameters afterwards.

I'm not sure what the fix is for this.




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Kjartan Maraas 2004-03-29 15:16:46 EST
Filed upstream as http://bugzilla.gnome.org/show_bug.cgi?id=138438
Comment 2 Owen Taylor 2004-08-03 11:43:29 EDT
Fixed upstream. It's actually a real bug since the second
parameter is extraneous not the third, but libgnomeprintui-2.0
is virtually unused in fc2, not in rhel3, and won't be in 
fc3, so I'm going to leave it unfixed.

Note You need to log in before you can comment on or make changes to this bug.