Bug 114992 - printf problem and void function return type
Summary: printf problem and void function return type
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: libmusicbrainz (Show other bugs)
(Show other bugs)
Version: 1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-05 09:54 UTC by d.binderman
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-12 17:14:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description d.binderman 2004-02-05 09:54:34 UTC
Description of problem:

I just tried to compile package libmusicbrainz-2.0.2-5 from Redhat
Fedora Core 1.

The compiler said

1.

browser.c:84: warning: too many arguments for format

The source code is

       sprintf(newBrowser, "%s\"%%s\"", browser, ptr + 2);

Perhaps the programmer didn't know that %% specifies %. Perhaps

       sprintf(newBrowser, "%s\"%%%s\"", browser, ptr + 2);

was intended.

2.

tiger.c(162): remark #1011: missing return statement at end of
non-void function "tiger_compress"

The source code is

/* The compress function is a function. Requires smaller cache?    */
tiger_compress(word64 *str, word64 state[3])
{
  tiger_compress_macro(((word64*)str), ((word64*)state));
}

Suggest make function have void return type.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:


Note You need to log in before you can comment on or make changes to this bug.