Bug 114993 - printf-style problem
printf-style problem
Status: CLOSED DUPLICATE of bug 78707
Product: Fedora
Classification: Fedora
Component: libungif (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Blandford
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-05 04:56 EST by d.binderman
Modified: 2013-04-02 00:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2004-02-05 04:56:47 EST
Description of problem:

I just tried to compile package libungif-4.1.0-16 from Redhat
Fedora Core 1.

The compiler said

1.

gifinfo.c:163: warning: too few arguments for format

The source code is

	fprintf(stderr, "Image %d is not confined to screen dimension,
aborted.\n");

Suggest either remove the %d specifier, or add an extra parameter.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jef Spaleta 2004-02-25 11:27:33 EST
Even though this is a newer package, the same warning is being
generated from the same line in the gifinfo.c file, so i'm going to
mark this as a duplicate of the bug from the older package.

Though, since you have already dug in and found what's causing the
error. You might be able to go a step further and easily provide a
patch that fixes this problem by figuring out which variable is
suppose to be that missing extra parameter corresponding to image
number. I'd tell you to check upstream to see if its fixed at 
http://prtr-13.ucsc.edu/~badger/software/libungif/
but i can't seem to get through to that site. Instead please try the
latest version of this package in the fedora core development tree
and create a patch against that if the problem is still present.   

*** This bug has been marked as a duplicate of 78707 ***
Comment 2 d.binderman 2004-02-25 16:32:53 EST
>You might be able to go a step further and easily provide a
>patch that fixes this problem

I would very much like to be able to do this, but I can't.

I've found bugs in over 200 Redhat Fedora core packages.
I simply don't have the time or resource to fix every bug.

I've gone part of the way in finding the obvious bug.
Maybe Redhat would be interested in fixing the bugs I've found,
maybe even the ones which have been around since Redhat 8.0 
and still aren't fixed.

>but i can't seem to get through to that site.

Nor can I. 
Comment 3 Red Hat Bugzilla 2006-02-21 14:01:05 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.