Bug 114994 - Missing return expression & printf problem
Missing return expression & printf problem
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libwpd (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-05 04:59 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-29 18:07:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2004-02-05 04:59:01 EST
Description of problem:

I just tried to compile package libwpd-0.6.2-1 from Redhat
Fedora Core 1.

The compiler said

1.

RawListener.cpp:109: warning: too few arguments for format

The source code is

        printf("<DATE SET year: %i month: %i day: %i hour: %i minute:
%i second: %i dayOfWeek: %i timeZone: %i unused: %i>\n");

Quite a few missing parameters here.

2.

libwpd_support.cpp(623): warning #1011: missing return statement at
end of non-void function "UTF8String::operator="

The source code is

UTF8String & UTF8String::operator=(const UTF8String &str)
{
        // FIXME FIXME FIXME (IMPORTANT): Protect against the case of
        // self assignment (x=x)
        m_buf = g_string_assign(m_buf, str.getUTF8());
}

Have they not considered the missing return statement ?



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Marc Maurer 2004-02-07 10:16:26 EST
This is fixed in the latest libwpd releases.
Comment 2 Caolan McNamara 2004-04-29 18:07:47 EDT
Yep. Fedora Core 2 is now using libwpd 0.7.1 and those two sections of
problematic code are now commented so the problem is resolved.

Note You need to log in before you can comment on or make changes to this bug.