Bug 115010 - Nautilus does not launch default app viewer upon double click
Nautilus does not launch default app viewer upon double click
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-05 10:07 EST by James Laska
Modified: 2013-09-02 01:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-09 06:35:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Laska 2004-02-05 10:07:36 EST
I double click on a png file on my desktop.  EOG does not open despite
being selected as the default app viewer (or at least in the
right-click open-with menu).  $HOME/.xsession-errors shows the
following messages when I click.

** (nautilus:10007): WARNING **: Failed to lock:  No such file or
directory

When I kill nautilus (pkill nautilus) and it restarts (thanks to
gnome-session), it then launches all the EOG windows that my
double-clicks requested.
Comment 1 James Laska 2004-02-05 10:08:15 EST
forgot to mention I'm running with the rawhide-latest/i386 (with the
exception of a newer gnome-vfs2-2.5.6-2
Comment 2 James Laska 2004-02-05 10:25:50 EST
I'm thinking this may be eog's fault (and not nautilus)...but it is
odd that when I kill nautilus, eog starts.

WHen I try to run eog by hand...I get nothing...strace shows it
eventually sitting on:

read(16, "/tmp/.famgnTK5i\0", 16)       = 16
socket(PF_UNIX, SOCK_STREAM, 0)         = 17
connect(17, {sa_family=AF_UNIX, path="/tmp/.famgnTK5i"}, 110) = 0
close(16)                               = 0
getegid32()                             = 3633
geteuid32()                             = 3633
write(17, "\0\0\0\33", 4)               = 4
write(17, "N0 3633 3633 test-monitor\n\0", 27) = 27
fstat64(17, {st_mode=S_IFSOCK|0777, st_size=0, ...}) = 0
fcntl64(17, F_GETFL)                    = 0x2 (flags O_RDWR)
select(18, [17], NULL, NULL, {0, 0})    = 0 (Timeout)
getgroups32(32, [3633, 502, 503])       = 3
geteuid32()                             = 3633
write(17, "\0\0\0004", 4)               = 4
write(17, "W1 3633 3633 /home/jlaska/.recen"..., 52) = 52
open("/home/jlaska/.recently-used", O_RDWR) = 16
fstat64(16, {st_mode=S_IFREG|0600, st_size=3966, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1,
0) = 0xf6e70000
_llseek(16, 0, [0], SEEK_SET)           = 0
fcntl64(16, F_SETLKW, {type=F_WRLCK, whence=SEEK_CUR, start=0, len=0}


which looks like it's doing a seek on the libfam file descriptor in /tmp ?

Updated the fam rpm from fam-2.6.8-12 to fam-2.6.10-1...  I can now
run eog from the console manually...but launching it from a nautilus
double-click still fails.  strace of the eog started by nautilus shows
it sitting on the same fnctl64() above.
Comment 3 Alexander Larsson 2004-02-09 06:35:19 EST
This is a problem with recent-files locking. Its fixed upstream and
will be in the next nautilus release.

Note You need to log in before you can comment on or make changes to this bug.