Bug 1150241 - [abrt] scons: Executor.py:396:prepare:StopError: Source `/usr/lib64/libpng.a' not found, needed by target `misc/libpng.a'.
Summary: [abrt] scons: Executor.py:396:prepare:StopError: Source `/usr/lib64/libpng.a'...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: scons
Version: 20
Hardware: x86_64
OS: Unspecified
low
unspecified
Target Milestone: ---
Assignee: Mosaab Alzoubi
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:0478b9853f929db1d10f668c319...
Depends On:
Blocks: 1150637
TreeView+ depends on / blocked
 
Reported: 2014-10-07 18:37 UTC by Raphael Groner
Modified: 2015-08-08 01:37 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-25 15:28:23 UTC
fdc: needinfo-


Attachments (Terms of Use)
File: backtrace (715 bytes, text/plain)
2014-10-07 18:37 UTC, Raphael Groner
no flags Details
File: paintown.spec (1.46 KB, text/plain)
2014-10-07 18:37 UTC, Raphael Groner
no flags Details

Description Raphael Groner 2014-10-07 18:37:21 UTC
Description of problem:
rpmbuild -bb paintown.spec (uses cmake and scons)

Version-Release number of selected component:
scons-2.3.4-1.fc20

Additional info:
reporter:       libreport-2.2.3
cmdline:        /usr/bin/python /usr/bin/scons -j 4
executable:     /usr/bin/scons
kernel:         3.16.3-200.fc20.x86_64
type:           Python

Truncated backtrace:
Executor.py:396:prepare:StopError: Source `/usr/lib64/libpng.a' not found, needed by target `misc/libpng.a'.

Traceback (most recent call last):
  File "/usr/lib/scons/SCons/Job.py", line 199, in start
    task.prepare()
  File "/usr/lib/scons/SCons/Taskmaster.py", line 191, in prepare
    executor.prepare()
  File "/usr/lib/scons/SCons/Executor.py", line 396, in prepare
    raise SCons.Errors.StopError(msg % (s, self.batches[0].targets[0]))
StopError: Source `/usr/lib64/libpng.a' not found, needed by target `misc/libpng.a'.

Local variables in innermost frame:
msg: "Source `%s' not found, needed by target `%s'."
s: <SCons.Node.FS.File object at 0xfc1150>
self: <SCons.Executor.Executor object at 0xfcae10>

Comment 1 Raphael Groner 2014-10-07 18:37:24 UTC
Created attachment 944709 [details]
File: backtrace

Comment 2 Raphael Groner 2014-10-07 18:37:26 UTC
Created attachment 944710 [details]
File: paintown.spec

Comment 3 Raphael Groner 2014-10-07 18:47:25 UTC
Maybe some help:
http://www.scons.org/doc/2.2.0/HTML/scons-user/x4974.html

Comment 4 Raphael Groner 2014-10-11 16:22:04 UTC
scons works nevertheless but still it is a punishment to abrt and may be confusing.

Comment 5 Raphael Groner 2014-10-31 14:24:43 UTC
Ping?

Since paintown is not easily packable, I am thinking about closing CANTFIX this bug as well.

Comment 6 Raphael Groner 2015-01-30 20:45:20 UTC
Is this reproducible for you?

Comment 7 Raphael Groner 2015-02-25 15:28:23 UTC
No reply from maintainer since monthes … :((

Comment 8 Mosaab Alzoubi 2015-08-08 01:37:19 UTC
Is problem still found ?


Note You need to log in before you can comment on or make changes to this bug.