Bug 115025 - Installer freezes at start up X windows
Installer freezes at start up X windows
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-05 11:53 EST by Bert Rodiers
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-12 14:47:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bert Rodiers 2004-02-05 11:53:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
I have a MSI RADEON 9800 XL graphic card and a 19"TFT screen (MEDION,
model name:MD7212AT, TypeNo:EZM19K). The install program probes the
graphic card as a ATI RADEON 9800 PRO and generic monotor and X starts
but immediately everything freezes. I'm unable to do anything further.
Therefore I tried again with the text installer. After everything has
been installed the computer reboots normally and then X starts and I
can proceed with the installation, BUT after having chosen some
settings I have to accept the Terms of use. When I do this and click
on next everything freezes.
When I then reboot and go into the interactive booting and don't start
firstboot I can log in using the graphical screen (in gdm), gnome
starts, but after a while everything freezes.
Probably the driving for my graphic card doesn't support my card well.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.start the installation
2.after probing, X starts and everything freezes
    

Actual Results:  everything freezes

Expected Results:  the setup continuous normally :-)

Additional info:
Comment 1 Bert Rodiers 2004-02-05 12:12:32 EST
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=109256 seems to
be related (although he's talking about a ATI RADEON 9800 and I have a
MSI RADEON 9800XL (more info about this card:
http://www.xbitlabs.com/news/video/display/20031120092217.html))
Comment 2 Mike A. Harris 2004-02-05 16:06:04 EST
The bug reports are related, and there are various others open in
bugzilla as well.  I have been leaving them open rather than closing
them as duplicates for the time being, in order to gather XFree86
log files from people, so that when I dig into the various Radeon
issues, I'll have as many details as possible to work with.

Can you do a text-mode install, and then do:

redhat-config-xfree86 --reconfig

Please bugzilla file attach your uncompressed X server log file from
after trying to start up X, as well as the output of:

lspci -vv
lspci -vvn

I'll add this to my radeon tracker, and a future update should
fix the problems.

TIA
Comment 3 Alfonso Centuori 2004-05-30 20:35:59 EDT
I have a notebook DELL Latitude D505 with an LCD screen 1024x768 and 
after I've installed with "linux text" all the system, when it tries 
to reboot after the installation is done, it hangs there in a 
greenish screen and everything is hard locked. I need to push the 
power on button to change the status. Then I tried to reboot with the 
installation CD with the options "nousb" or "noprobe" or "nopr" or 
whatever other option was available. But nothing. I tried to read all 
the bug list but in no one something useful for me it is said. So 
that's why I'm disturbing you. What else can I try to do? It 
says "Probing for monitor type:  unknown" but during the installation 
I selected DELL Notebook 1024x768...but at the end at the reboot 
after the installation it stopped when trying to activate X....

I'm hopeless...

Thanks,

Alfonso
Comment 4 Mike A. Harris 2004-10-12 14:47:53 EDT
Since this bugzilla report was filed, there have been several major
updates to the X Window System, which may resolve this issue.  Users
who have experienced this problem are encouraged to upgrade to the
latest version of Fedora Core, which can be obtained from:

        http://fedora.redhat.com/download

If this issue turns out to still be reproduceable in the latest
version of Fedora Core, please file a bug report in the X.Org
bugzilla located at http://bugs.freedesktop.org in the "xorg"
component.

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Note You need to log in before you can comment on or make changes to this bug.