Bug 1150384 - unicode_start is not started on boot
Summary: unicode_start is not started on boot
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: dracut-maint-list
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1012653 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-08 06:46 UTC by Daniel Mach
Modified: 2015-05-25 11:13 UTC (History)
17 users (show)

Fixed In Version: dracut-038-31.git20141204.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-15 04:28:53 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1151651 None None None Never

Internal Links: 1151651

Description Daniel Mach 2014-10-08 06:46:58 UTC
Reproducer:

$ cat /etc/vconsole.conf 
KEYMAP="us"
FONT="latarcyrheb-sun16"

boot to console, login

$ loadkeys cz

type non-ascii characters

Result:
▀▀▀▀▀▀▀▀▀

Expected result:
ěščřžýáíé

Everything works as expected after running:
$ unicode_start

I think systemd (or dracut?) simply doesn't run unicode_start on boot.

Comment 1 Jan Synacek 2014-10-14 07:09:36 UTC
There already is a service for that (systemd-vconsole-setup), but it doesn't seem to be run at startup. Restarting the service manually after login works for me.

As a temporary fix, you can:
1) edit /usr/lib/systemd/system/systemd-vconsole-setup.service and remove RemainAfterExit=yes from that file
2) dracut -f
3) edit /usr/lib/systemd/system/systemd-vconsole-setup.service and add RemainAfterExit=yes back

Then, whenever you login, unicode characters should be displayed properly.

Comment 2 Jan Synacek 2014-10-14 07:35:29 UTC
I forgot step 4) reboot.

Comment 4 Fedora Update System 2014-11-27 14:26:29 UTC
systemd-216-12.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/systemd-216-12.fc21

Comment 5 Fedora Update System 2014-11-27 19:29:18 UTC
Package systemd-216-12.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-216-12.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-15919/systemd-216-12.fc21
then log in and leave karma (feedback).

Comment 6 Adam Williamson 2014-11-28 01:35:36 UTC
This looks like something we might want as an FE so unicode characters are displayed correctly in live images etc? Proposing. Also adding CommonBugs.

Comment 7 Kevin Fenzi 2014-11-28 02:41:48 UTC
+1 FE.

Comment 8 Mike Ruckman 2014-12-01 17:47:20 UTC
Discussed in 2014-12-01 blocker review meeting. Accepted as an FE: we're obviously reluctant to touch systemd this late, but the change is very limited and the bug seems fairly bad for many non-US users (and even some US users who speak those furrin languages).

Comment 9 Ray Strode [halfline] 2014-12-02 15:03:40 UTC
note this fix requires a dracut fix as well...

http://git.kernel.org/cgit/boot/dracut/dracut.git/commit/?id=027565d0233f76edf434b63a847a717185d267e2

Comment 10 Adam Williamson 2014-12-02 17:51:58 UTC
gah. that information would've been useful 12 hours ago, when rc2 was composing. :( oh, well.

Comment 11 Fedora Update System 2014-12-03 17:15:59 UTC
systemd-216-12.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Adam Williamson 2014-12-03 19:05:08 UTC
Re-opening per c#9, as apparently this isn't fixed until we make a change in dracut too. (no, I am not taking any changes to dracut for F21 RC5, I remember what happened with last-minute dracut changes in F20...but for normal Bugzilla purposes, the bug should be open.)

Comment 13 Fedora Update System 2014-12-04 11:22:17 UTC
dracut-038-31.git20141204.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/dracut-038-31.git20141204.fc21

Comment 14 Fedora Update System 2014-12-05 00:47:08 UTC
Package dracut-038-31.git20141204.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dracut-038-31.git20141204.fc21'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-16288/dracut-038-31.git20141204.fc21
then log in and leave karma (feedback).

Comment 15 Adam Williamson 2014-12-05 19:47:50 UTC
21 is done, cleaning blocker/FE process metadata.

Comment 16 Adam Williamson 2014-12-08 02:10:56 UTC
Ray: so I'm a bit confused - you say this needs a dracut fix too, but 'raven' reported on the update https://admin.fedoraproject.org/updates/FEDORA-2014-15919/systemd-216-12.fc21: 

" raven - 2014-11-28 16:55:34
Works fine, fixes bug #1150384 for me. "

Is that a mis-test? Or can this work in some cases without the dracut fix? Does it depend on whether the console output driver change occurs in initramfs or after?

Comment 17 Harald Hoyer 2014-12-08 15:07:19 UTC
(In reply to Adam Williamson (Red Hat) from comment #16)
> Ray: so I'm a bit confused - you say this needs a dracut fix too, but
> 'raven' reported on the update
> https://admin.fedoraproject.org/updates/FEDORA-2014-15919/systemd-216-12.
> fc21: 
> 
> " raven - 2014-11-28 16:55:34
> Works fine, fixes bug #1150384 for me. "
> 
> Is that a mis-test? Or can this work in some cases without the dracut fix?
> Does it depend on whether the console output driver change occurs in
> initramfs or after?

I think, this can be the case here.

Comment 18 Ray Strode [halfline] 2014-12-08 20:59:50 UTC
right, it will work in some cases without the dracut fix (for instance, no plymouth, or slow graphic bring up)

Comment 19 Jan Synacek 2014-12-11 08:29:58 UTC
*** Bug 1012653 has been marked as a duplicate of this bug. ***

Comment 20 Fedora Update System 2014-12-15 04:28:53 UTC
dracut-038-31.git20141204.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.