Bug 115039 - vmlinux should be included in 2.6 kernel RPM
Summary: vmlinux should be included in 2.6 kernel RPM
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i686 Linux
medium
low
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-05 19:16 UTC by Paul Bender
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-07 09:56:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Paul Bender 2004-02-05 19:16:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
With the 2.6.x kernel RPMs, it appears that vmlinux has been moved to
the kernel-debuginfo RPM.

Some third party kernel modules require vmlinux in order to build.
During the build process, these modules use modpost, which takes
vmlinux as its first argument. As a result, these modules cannot be
built without installing the kernel-debuginfo package or rebuilding
the kernel.

Not having done any kernel module development, I am assuming that
these modules need to use modpost (and therefore vmlinux) during the
build process. If this is not the case, then could someone let me know
so that I can inform the module developers.

Anyway, since some third party modules require vmlinux to build, it
would seem more sensible to include vmlinux in an RPM other than the
kernel-debuginfo RPM. If a kernel-devel RPM existed, then it would
make sense to include it there. Since no kernel-devel RPM exists, I
think that vmlinuz should be included in the kernel RPM.

One example of modules that require vmlinux are the MADWIFI drivers
available at <http://sourceforge.net/projects/madwifi/>.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
(1) Install kernel-2.6.1-1.65.i686.rpm, but do not install
corresponding debuginfo RPM.
(2) Boot using the 2.6.1-1.65 kernel.
(3) Download the MADWIFI drivers from CVS at
<http://sourceforge.net/projects/madwifi/>.
(4) Compile the MADWIFI drivers.

Actual Results:  MADWIFI compilation fails because it cannot find vmlinux.

Expected Results:  I would expect vmlinux to be present.

Additional info:

Comment 1 Arjan van de Ven 2004-02-07 09:56:56 UTC
this needs to be fixed in the madwifi stuf then.


Comment 2 Paul Bender 2004-02-07 15:26:25 UTC
Could you please provide more information?
Do you mean that madwifi is not supposed to be uing modpost?

Comment 3 Arjan van de Ven 2004-02-07 15:28:02 UTC
not by itself for sure


Note You need to log in before you can comment on or make changes to this bug.