Bug 1150420 - Users > Take a photo for user picture crashes control center.
Summary: Users > Take a photo for user picture crashes control center.
Keywords:
Status: CLOSED DUPLICATE of bug 1121294
Alias: None
Product: Fedora
Classification: Fedora
Component: cheese
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-08 09:16 UTC by Tuomas Kuosmanen
Modified: 2014-10-15 14:44 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-15 14:44:06 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 697039 None None None Never

Description Tuomas Kuosmanen 2014-10-08 09:16:49 UTC
Description of problem: Taking user photo via webcam crashes control center


Version-Release number of selected component (if applicable): Fedora 21, control-center-3.14.0-1.fc21.x86_64


How reproducible: always


Steps to Reproduce:
1. Open Settings > Users, click user picture
2. Select "Take photo"
3. Click camera icon

Actual results: Snaps picture, screen flashes white for illumination, crash.

Additional info:

Program received signal SIGSEGV, Segmentation fault.
0x00007ffff1b5eff4 in gtk_widget_verify_invariants (widget=0x2a5e9e0) at gtkwidget.c:10038
10038	  if (widget->priv->verifying_invariants_count > 0)
(gdb) bt
#0  0x00007ffff1b5eff4 in gtk_widget_verify_invariants (widget=0x2a5e9e0) at gtkwidget.c:10038
#1  0x00007ffff19eacd0 in gtk_frame_forall (container=<optimized out>, include_internals=<optimized out>, callback=0x7ffff1b5f3a0 <gtk_widget_verify_child_invariants>, callback_data=0x0) at gtkframe.c:368
#2  0x00007ffff19f13c0 in gtk_grid_forall (container=<optimized out>, include_internals=<optimized out>, callback=0x7ffff1981e90 <gtk_container_map_child>, callback_data=0x0) at gtkgrid.c:552
#3  0x00007ffff19854df in gtk_container_map (widget=0xb6a510 [GtkGrid]) at gtkcontainer.c:3445
#7  0x00007ffff02343bf in <emit signal ??? on instance 0xb6a510 [GtkGrid]> (instance=instance@entry=0xb6a510, signal_id=<optimized out>, detail=detail@entry=0) at gsignal.c:3365
    #4  0x00007ffff0219d35 in g_closure_invoke (closure=closure@entry=0x998e00, return_value=return_value@entry=0x0, n_param_values=1, param_values=param_values@entry=0x7fffffffd140, invocation_hint=invocation_hint@entry=0x7fffffffd0e0)
    at gclosure.c:768
    #5  0x00007ffff022b35c in signal_emit_unlocked_R (node=node@entry=0x998e50, detail=detail@entry=0, instance=instance@entry=0xb6a510, emission_return=emission_return@entry=0x0, instance_and_params=instance_and_params@entry=0x7fffffffd140)
    at gsignal.c:3483
    #6  0x00007ffff0234191 in g_signal_emit_valist (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>, var_args=var_args@entry=0x7fffffffd2c0) at gsignal.c:3309
#8  0x00007ffff1b70479 in gtk_widget_map (widget=0xb6a510 [GtkGrid]) at gtkwidget.c:5045
#9  0x00007ffff1b7066c in gtk_widget_set_child_visible (widget=0xb6a510 [GtkGrid], is_visible=<optimized out>)
    at gtkwidget.c:10537
#10 0x00007ffff1a6567f in gtk_notebook_real_switch_page (notebook=0x25a43c0 [GtkNotebook], child=<optimized out>, page_num=<optimized out>) at gtknotebook.c:6736
#14 0x00007ffff02343bf in <emit signal ??? on instance 0x25a43c0 [GtkNotebook]> (instance=instance@entry=0x25a43c0, signal_id=<optimized out>, detail=detail@entry=0) at gsignal.c:3365
    #11 0x00007ffff0219d35 in g_closure_invoke (closure=closure@entry=0x9aef90, return_value=return_value@entry=0x0, n_param_values=3, param_values=param_values@entry=0x7fffffffd5d0, invocation_hint=invocation_hint@entry=0x7fffffffd570)
    at gclosure.c:768
    #12 0x00007ffff022b94a in signal_emit_unlocked_R (node=node@entry=0x9ba740, detail=detail@entry=0, instance=instance@entry=0x25a43c0, emission_return=emission_return@entry=0x0, instance_and_params=instance_and_params@entry=0x7fffffffd5d0)
    at gsignal.c:3591
    #13 0x00007ffff0234191 in g_signal_emit_valist (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>, var_args=var_args@entry=0x7fffffffd780) at gsignal.c:3309
#15 0x00007ffff1a5e79d in gtk_notebook_switch_page (notebook=notebook@entry=0x25a43c0 [GtkNotebook], page=<optimized out>)
    at gtknotebook.c:6778
#16 0x00007ffff1a669f4 in gtk_notebook_set_current_page (notebook=0x25a43c0 [GtkNotebook], page_num=1) at gtknotebook.c:7347
#17 0x00007ffff4fee848 in cheese_widget_photo_taken_cb () at /lib64/libcheese-gtk.so.23
#18 0x00007ffff021d00b in g_cclosure_marshal_VOID__OBJECTv (closure=0x2c64670, return_value=<optimized out>, instance=<optimized out>, args=<optimized out>, marshal_data=0x0, n_params=<optimized out>, param_types=0xb52ec0) at gmarshal.c:1312
#19 0x00007ffff0219f64 in _g_closure_invoke_va (closure=0x2a5e9e0, 
    closure@entry=0x2c64670, return_value=return_value@entry=0x0, instance=0x0, instance@entry=0x9fc7b0, args=0x1, 
    args@entry=0x7fffffffdaf0, n_params=38435200, param_types=0x28) at gclosure.c:831
#20 0x00007ffff0233b70 in g_signal_emit_valist (instance=0x9fc7b0, signal_id=<optimized out>, detail=0, var_args=var_args@entry=0x7fffffffdaf0) at gsignal.c:3218
#21 0x00007ffff02343bf in g_signal_emit (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>)
    at gsignal.c:3365
#22 0x00007ffff4ddeadf in cheese_camera_bus_message_cb () at /lib64/libcheese.so.7
#23 0x00007ffff021cd03 in g_cclosure_marshal_VOID__BOXEDv (closure=0x2b63d20, return_value=<optimized out>, instance=<optimized out>, args=<optimized out>, marshal_data=<optimized out>, n_params=<optimized out>, param_types=0xa1bec0) at gmarshal.c:1160
#24 0x00007ffff0219f64 in _g_closure_invoke_va (closure=0x2a5e9e0, 
    closure@entry=0x2b63d20, return_value=return_value@entry=0x0, instance=0x0, instance@entry=0x2a7e170, args=0x1, 
    args@entry=0x7fffffffdee0, n_params=38435200, param_types=0x28) at gclosure.c:831
#25 0x00007ffff0233b70 in g_signal_emit_valist (instance=0x2a7e170, signal_id=<optimized out>, detail=2139, var_args=var_args@entry=0x7fffffffdee0) at gsignal.c:3218
#26 0x00007ffff02343bf in g_signal_emit (instance=<optimized out>, signal_id=<optimized out>, detail=<optimized out>)
    at gsignal.c:3365
#27 0x00007fffe6473fb2 in gst_bus_async_signal_func () at /lib64/libgstreamer-1.0.so.0
#28 0x00007fffe6474d1d in gst_bus_source_dispatch () at /lib64/libgstreamer-1.0.so.0
#29 0x00007fffeff1aafb in g_main_context_dispatch (context=0x9cc790) at gmain.c:3111
#30 0x00007fffeff1aafb in g_main_context_dispatch (context=context@entry=0x9cc790) at gmain.c:3710
#31 0x00007fffeff1ae98 in g_main_context_iterate (context=context@entry=0x9cc790, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3781
#32 0x00007fffeff1af4c in g_main_context_iteration (context=0x9cc790, context@entry=0x0, may_block=may_block@entry=1)
    at gmain.c:3842
#33 0x00007ffff050007c in g_application_run (application=0x99f0f0 [CcApplication], argc=1, argv=0x7fffffffe278)
    at gapplication.c:2282
---Type <return> to continue, or q <return> to quit---
#34 0x000000000044c51b in main ()
(gdb)

Comment 1 Ondrej Holy 2014-10-08 16:12:06 UTC
I'm afraid this is cheese issue, because we are just showing dialog provided by cheese...

Comment 2 Tuomas Kuosmanen 2014-10-09 07:33:27 UTC
Bug#1140303 looks similar.

Comment 3 Jeremy Rimpo 2014-10-14 15:23:29 UTC
Initially there was a different error, which was mirrored by cheese itself, resulting in Bug#1121294 - however, since that bug was fixed, this new error has occurred within the gnome control center.

This error also occurs running on f20 with the Gnome 3.12.x copr repo.

Comment 4 David King 2014-10-15 14:44:06 UTC
This turned out to be a symbol collision, and was fixed in the control center.

*** This bug has been marked as a duplicate of bug 1121294 ***


Note You need to log in before you can comment on or make changes to this bug.