Bug 1150428 - [iscsi] can't live migrate VM's disk: CanDoAction of action CreateAllSnapshotsFromVm failed. Reasons:VAR__ACTION__CREATE,VAR__TYPE__SNAPSHOT,ACTION_TYPE_FAILED_QEMU_UNSUPPORTED_OPERATION
Summary: [iscsi] can't live migrate VM's disk: CanDoAction of action CreateAllSnapshot...
Keywords:
Status: CLOSED DUPLICATE of bug 1149460
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.5.0
Assignee: Tal Nisan
QA Contact:
URL:
Whiteboard: storage
Depends On: 1149667
Blocks: 1147971
TreeView+ depends on / blocked
 
Reported: 2014-10-08 09:44 UTC by Jiri Belka
Modified: 2016-02-10 17:34 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-15 13:53:19 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)
sosreport-LogCollector-20141008113705.7z (19.53 MB, application/x-7z-compressed)
2014-10-08 09:44 UTC, Jiri Belka
no flags Details
sosreport-LogCollector-20141008113705.7z (2nd volume) (2.23 MB, application/octet-stream)
2014-10-08 09:45 UTC, Jiri Belka
no flags Details

Description Jiri Belka 2014-10-08 09:44:43 UTC
Created attachment 944897 [details]
sosreport-LogCollector-20141008113705.7z

Description of problem:

I can't do live disk migration on ISCSI domain, the live disk migration is not even logged:

- there's no live disk migration event
- there's no error event about failing such action

The disk in VM->Disks subtab has "in progress" icon.

In Tasks I see:

- X Creating VM Snapshot Auto-generated for Live Storage Migration for VM test
  X Validating
- X Launching VM test
  ... X for Executing and Validating

Then I see strange events:
	
2014-Oct-08, 11:19	
Add-Disk operation of 'OVF_STORE' was initiated by <UNKNOWN>.
	
2014-Oct-08, 11:19	
Add-Disk operation of 'OVF_STORE' was initiated by <UNKNOWN>.

<UNKNOWN> ??? It was admin@internal. Why twice?

Version-Release number of selected component (if applicable):
rhevm-backend-3.5.0-0.14.beta.el6ev.noarch
vdsm-4.16.6-1.el6ev.x86_64

How reproducible:
100%

Steps to Reproduce:
1. 1 DC, 2 iscsi storage domains
2. create a VM with 1 disk on one storage domain (preallocated as it is default)
3. start VM
4. live storage migration for VM's disk

Actual results:
didn't pass; disk icon is "in progress", no events for start of the action and no event about fail of the action

Expected results:
events and the action should pass

Additional info:

Comment 1 Jiri Belka 2014-10-08 09:45:54 UTC
Created attachment 944899 [details]
sosreport-LogCollector-20141008113705.7z (2nd volume)

Comment 2 Jiri Belka 2014-10-08 09:47:44 UTC
...
2014-10-08 11:07:52,085 INFO  [org.ovirt.engine.core.bll.MoveDisksCommand] (ajp-/127.0.0.1:8702-6) [11754d0a] Running command: MoveDisksCommand internal: false. Entities affected :  ID: 0dbe1f65-c19d-4e40-941c-bf912d2380fa Type: DiskAction group CONFIGURE_DISK_STORAGE with role type USER
2014-10-08 11:07:52,213 INFO  [org.ovirt.engine.core.bll.lsm.LiveMigrateVmDisksCommand] (ajp-/127.0.0.1:8702-6) [11754d0a] Lock Acquired to object EngineLock [exclusiveLocks= key: 0dbe1f65-c19d-4e40-941c-bf912d2380fa value: DISK
, sharedLocks= key: 057790fa-b736-49e7-a7c1-4c832c1c3511 value: VM
]
2014-10-08 11:07:52,306 INFO  [org.ovirt.engine.core.bll.lsm.LiveMigrateVmDisksCommand] (org.ovirt.thread.pool-7-thread-2) [11754d0a] Running command: LiveMigrateVmDisksCommand Task handler: LiveSnapshotTaskHandler internal: false. Entities affected :  ID: 0dbe1f65-c19d-4e40-941c-bf912d2380fa Type: DiskAction group CONFIGURE_DISK_STORAGE with role type USER,  ID: a27ef16b-ef58-4130-8d71-e5183b8556d5 Type: StorageAction group CREATE_DISK with role type USER
2014-10-08 11:07:52,353 INFO  [org.ovirt.engine.core.bll.CreateAllSnapshotsFromVmCommand] (org.ovirt.thread.pool-7-thread-2) Command acdcf669-eada-42f1-a4fc-5614954471f4 persisting async task placeholder for child command be573c8f-6df7-4a60-973c-2e56e9f56fd2
2014-10-08 11:07:52,508 WARN  [org.ovirt.engine.core.bll.CreateAllSnapshotsFromVmCommand] (org.ovirt.thread.pool-7-thread-2) CanDoAction of action CreateAllSnapshotsFromVm failed. Reasons:VAR__ACTION__CREATE,VAR__TYPE__SNAPSHOT,ACTION_TYPE_FAILED_QEMU_UNSUPPORTED_OPERATION

^^^^ just WARNING?

2014-10-08 11:07:52,523 INFO  [org.ovirt.engine.core.bll.tasks.AsyncTaskManager] (org.ovirt.thread.pool-7-thread-2) Removed task f0bbbd7a-5988-4f3e-a626-cf2d13de0e10 from DataBase
2014-10-08 11:07:52,532 INFO  [org.ovirt.engine.core.bll.lsm.LiveMigrateVmDisksCommand] (org.ovirt.thread.pool-7-thread-2) Lock freed to object EngineLock [exclusiveLocks= key: 0dbe1f65-c19d-4e40-941c-bf912d2380fa value: DISK
, sharedLocks= key: 057790fa-b736-49e7-a7c1-4c832c1c3511 value: VM
]
2014-10-08 11:19:49,271 INFO  [org.ovirt.engine.core.bll.OvfDataUpdater] (DefaultQuartzScheduler_Worker-57) Attempting to update VMs/Templates Ovf.
2014-10-08 11:19:49,384 INFO  [org.ovirt.engine.core.bll.ProcessOvfUpdateForStorageDomainCommand] (DefaultQuartzScheduler_Worker-57) [59a80906] Lock Acquired to object EngineLock [exclusiveLocks= key: a27ef16b-ef58-4130-8d71-e5183b8556d5 value: STORAGE
, sharedLocks= key: 00000002-0002-0002-0002-0000000001f1 value: OVF_UPDATE
]
2014-10-08 11:19:49,386 INFO  [org.ovirt.engine.core.bll.ProcessOvfUpdateForStorageDomainCommand] (DefaultQuartzScheduler_Worker-57) [59a80906] Running command: ProcessOvfUpdateForStorageDomainCommand internal: true. Entities affected :  ID: a27ef16b-ef58-4130-8d71-e5183b8556d5 Type: Storage
2014-10-08 11:19:49,397 INFO  [org.ovirt.engine.core.bll.CreateOvfStoresForStorageDomainCommand] (DefaultQuartzScheduler_Worker-57) [7c5ab734] Running command: CreateOvfStoresForStorageDomainCommand internal: true.
2014-10-08 11:19:49,398 INFO  [org.ovirt.engine.core.bll.CreateOvfVolumeForStorageDomainCommand] (DefaultQuartzScheduler_Worker-57) [27b1f6b4] Running command: CreateOvfVolumeForStorageDomainCommand internal: true. Entities affected :  ID: a27ef16b-ef58-4130-8d71-e5183b8556d5 Type: Storage
2014-10-08 11:19:49,412 INFO  [org.ovirt.engine.core.bll.AddDiskCommand] (DefaultQuartzScheduler_Worker-57) [406210b0] Running command: AddDiskCommand internal: true. Entities affected :  ID: a27ef16b-ef58-4130-8d71-e5183b8556d5 Type: StorageAction group CREATE_DISK with role type USER
2014-10-08 11:19:49,462 INFO  [org.ovirt.engine.core.bll.AddImageFromScratchCommand] (DefaultQuartzScheduler_Worker-57) [7329d863] Running command: AddImageFromScratchCommand internal: true. Entities affected :  ID: a27ef16b-ef58-4130-8d71-e5183b8556d5 Type: Storage
...

Comment 3 Jiri Belka 2014-10-08 10:34:38 UTC
qemu-kvm-rhev-0.12.1.2-2.448.el6.x86_64

Comment 4 Michal Skrivanek 2014-10-10 17:27:01 UTC
Is this 6.6 with capabilities misreporting? Looks like that...

Comment 7 Francesco Romani 2014-10-14 16:35:29 UTC
live snapshot is indeed needed by live storage migration.

Seems same issue as per https://bugzilla.redhat.com/show_bug.cgi?id=1149667

Comment 8 Michal Skrivanek 2014-10-15 13:53:19 UTC
no need to track twice - closing

*** This bug has been marked as a duplicate of bug 1149460 ***


Note You need to log in before you can comment on or make changes to this bug.