Bug 115044 - hw tcp v4 csum failed
hw tcp v4 csum failed
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-05 15:14 EST by Jeffrey Siegal
Modified: 2013-07-02 22:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:01:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeffrey Siegal 2004-02-05 15:14:14 EST
Starting seeing "hw tcp v4 csum failed" messages in dmesg after
applying Update 1 errata.  By the way, these don't get recorded in
/var/log/messages (is that another bug?)

04:04.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100]
(rev 08)
        Subsystem: Intel Corp. EtherExpress PRO/100+ Server Adapter
(PILA8470B)
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- S ERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=medium
>TAbort- <TAbort- <MAbo rt- >SERR- <PERR-
        Latency: 32 (2000ns min, 14000ns max), cache line size 08
        Interrupt: pin A routed to IRQ 16
        Region 0: Memory at e1121000 (32-bit, non-prefetchable) [size=4K]
        Region 1: I/O ports at a000 [size=64]
        Region 2: Memory at e1000000 (32-bit, non-prefetchable) [size=1M]
        Expansion ROM at <unassigned> [disabled] [size=1M]
        Capabilities: [dc] Power Management version 2
                Flags: PMEClk- DSI+ D1+ D2+ AuxCurrent=0mA
PME(D0+,D1+,D2+,D3hot+,D3col d+)
                Status: D0 PME-Enable- DSel=0 DScale=2 PME-
 
eth0      Link encap:Ethernet  HWaddr [removed]
          inet addr:[removed]
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:43370997 errors:0 dropped:0 overruns:0 frame:0
          TX packets:15625129 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2511907860 (2395.5 Mb)  TX bytes:288840690 (275.4 Mb)
          Interrupt:16 Base address:0xa000 Memory:e1121000-e1121038
Comment 1 Jeffrey Siegal 2004-02-05 15:18:45 EST
Some additional information:

Messages started after approximately 15 days of uptime.  5 tcp
messages generated over about 24 hours, and also got one "udp v4 hw
csum failure."
Comment 2 Jeffrey Siegal 2004-02-12 04:28:39 EST
Also, the messages occurred solely in a period during which iptables
firewall was disabled. 

This was on a dual-Xeon system, SuperMicro P4DC6 motherboard using
onboard network adapter.
Comment 3 Jeff Garzik 2004-03-03 01:11:46 EST

*** This bug has been marked as a duplicate of 91236 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:01:06 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.