Bug 11505 - "cvs update" unable to patch files ?
Summary: "cvs update" unable to patch files ?
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cvs   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Eido Inoue
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-18 16:18 UTC by pgiannoz
Modified: 2007-04-18 16:27 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-08 14:14:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description pgiannoz 2000-05-18 16:18:58 UTC
After upgrading to RH6.2, cvs (version 1.10.7) seems unable to patch
updated files (patch version 2.5): the entire file is refetched.
This did not happern with RH6.0 (cvs version 1.10.5, patch 2.5).

Comment 1 Stephen Rasku 2000-07-18 19:51:28 UTC
This only seems to be a problem if you are using a local repository.  If you are
using pserver, it will still use patches.  I also checked this on CVS-1.10.8 on
Solaris at work and it's the same behaviour (patches for pserver, full update
for local).  Possible NOTABUG?

Comment 2 pgiannoz 2000-07-25 14:44:32 UTC
No, I am not using a local repository.  cvs tried to patch a file, then failed
without a message and reloaded the entire files. However I cannot reproduce any
longer this behavior, so my guess is 
that it was related in some nonobvious way (I had checked for obvious ways) to
my path.



Comment 3 pgiannoz 2000-10-06 13:50:32 UTC
> However I cannot reproduce any  longer this behavior

No, no, it is still there...the version in RH6.0, and the one I compiled:

   Concurrent Versions System (CVS) 1.10 `Halibut' (client/server)

patch files with no problem; the RH6.2 version

  Concurrent Versions System (CVS) 1.10.7 (client/server)

apparently fails to patch files, without any message, then reloads the entire
file

Comment 4 Eido Inoue 2004-10-08 14:14:06 UTC
foing bug cleanup. obsolete release... appears fixed in all current
support releases.


Note You need to log in before you can comment on or make changes to this bug.