Bug 115062 - When sharing to specific network is added, but not sharing to a specific interface, then r-c-p should do the right thing
When sharing to specific network is added, but not sharing to a specific inte...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: redhat-config-printer (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-05 18:07 EST by Aleksey Nogin
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-12 00:42:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 2004-02-05 18:07:31 EST
To reproduce:

On a single-interface machine, enable sharing to a specific range of
IP addresses (e.g 131.215.0.0/255.255.0.0) and activate.

Expected: it works or a warning is issued.

Actual: r-c-p adds a correct Allow to the cupsd.conf, but adds a
single "Listen" - "Listen 127.0.0.1:631". As a result, the specified
range of IP addresses do _not_ have the access they are supposed to have.

The workaround seems to be to allow sharing on the eth0 in addition to
allowing for the specified range. This is very confusing, since the
comments in cupsd.conf seems to imply that "@IF(eth0)" means
"everything connected via eth0", which in case of a single-NIC machine
whould mean "absolutely anybody"...
Comment 1 Tim Waugh 2004-02-06 05:12:46 EST
You don't say what version you are using.  This is critical
information, since there is a test package in the updates-testing
channel to fix this.

So which version of redhat-config-printer are you using?
Comment 2 Aleksey Nogin 2004-02-06 05:23:33 EST
Sorry, redhat-config-printer-0.6.79.2-1
Comment 3 Tim Waugh 2004-02-06 05:32:13 EST
Please try this first:

http://www.redhat.com/archives/fedora-test-list/2004-February/msg00054.html
Comment 4 Aleksey Nogin 2004-02-06 05:49:19 EST
Same problem still there. If I only ask for access to be allowed from
131.215.0.0/255.255.0.0, then the only "Listen" I get is "Listen
127.0.0.1:631", which means that no access is actually granted.
Specifically, what I get is:

<Location /printers/hp2300d>
Order Deny,Allow
Deny From All
Allow From 127.0.0.1
AuthType None
Allow from 131.215.0.0/255.255.0.0
</Location>
<Location />
Order Deny,Allow
Deny From All
Allow From 127.0.0.1
</Location>
Browsing On
BrowseProtocols cups
BrowseOrder Deny,Allow
BrowseDeny from All
Listen 127.0.0.1:631
Comment 5 Tim Waugh 2004-02-06 06:14:25 EST
What does /sbin/ifconfig say?
Comment 6 Aleksey Nogin 2004-02-06 06:22:28 EST
eth0      Link encap:Ethernet  HWaddr XX:XX:XX:XX:XX:XX
          inet addr:131.215.abc.def  Bcast:131.215.abc.255 
Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:635056 errors:0 dropped:0 overruns:1 frame:0
          TX packets:195282 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:98710133 (94.1 Mb)  TX bytes:39857027 (38.0 Mb)
          Interrupt:10 Base address:0xd800

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:19265 errors:0 dropped:0 overruns:0 frame:0
          TX packets:19265 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:11243704 (10.7 Mb)  TX bytes:11243704 (10.7 Mb)
Comment 7 Tim Waugh 2004-02-06 07:01:37 EST
Okay, this is the unfixed part of bug #109942.
Comment 8 Tim Waugh 2004-02-11 05:42:40 EST
There are now test update packages available for Fedora Core 1, which
should address the problem:

http://www.redhat.com/archives/fedora-test-list/2004-February/msg00231.html

Please test them out and verify that the problem is indeed fixed.  Thanks.

Comment 9 Aleksey Nogin 2004-02-11 21:23:21 EST
Confirming, redhat-config-printer-0.6.79.5-1 fixes this for me.
Comment 10 John Flanagan 2004-05-12 00:42:15 EDT
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-071.html

Note You need to log in before you can comment on or make changes to this bug.