Bug 115065 - startx and switchdesk hang if PS1 prompt is set strangely
startx and switchdesk hang if PS1 prompt is set strangely
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: XFree86 (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-05 18:37 EST by Brad Smith
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-07 15:34:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brad Smith 2004-02-05 18:37:37 EST
Description of problem:
I had two machines where students had 

PS1='[\h \W] :'

in their .bashrc files. When they ran startx (I think both users were
logged in as root at the time), the X server would start, but then
just sit there without ever appearing to run gnome-session. The server
would have to be killed with ctrl-alt-backspace. 'switchdesk gnome'
would also hang. I have no idea how the two could be related but once
the PS1 line was commented out of .bashrc and the student logged back
in startx worked properly again. 


Version-Release number of selected component (if applicable):
Rhel3 AS. I up2dated XFree86 and dependancies, but the problem persisted. 

How reproducible:
Seems readily reproducable. 

Steps to Reproduce:
1. add "PS1='[\h \W] :'" to .bashrc
2. logout and log back in 
3. run "startx"
  
Actual results:
X server starts, but no X clients appear. An strace stops in the
middle of reporting a call to waitpid()

Expected results:
Normal gnome session startup, which happens once the PS1 variable is
unset and startx is run again

Additional info:
Yes, I know it sounds ridiculous.
Comment 2 Mike A. Harris 2005-03-06 18:07:58 EST
Does the same thing occur if you create a new "dummy" user account
without any customization or other files present, and just add
the PS1 change to the new user's .bashrc?

Comment 3 Brad Smith 2005-03-07 12:58:04 EST
With a dummy user on a fully up2dated system this does not seem to be
reproducable. Either there was some other cause or the bug has been
fixed since I filed this report.

--Brad
Comment 4 Mike A. Harris 2005-03-07 15:34:05 EST
Ok, I'm going to close the report as "WORKSFORME" then, since
you've indicated it no longer occurs.  If the problem happens
again however, please contact Red Hat Global Support Services
via telephone at 1-888-RED-HAT1 and mention this bug ID, and
a support representative will assist you in troubleshooting the
problem.


Note You need to log in before you can comment on or make changes to this bug.