Bug 115068 - kdeaddons should not depend on xmms
kdeaddons should not depend on xmms
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdeaddons (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-05 22:22 EST by Keunwoo Lee
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-28 04:52:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keunwoo Lee 2004-02-05 22:22:39 EST
This is a companion to Bug 115067. 
 
I am using the Fedora KDE 3.2 packages on the KDE mirrors.  It's not 
on the official Fedora mirrors, but the packager field says Red Hat, 
so I'm reporting here in the hopes that it'll be fixed by official 
release. 
 
rpm --erase --test xmms yields the following: 
 
error: Failed dependencies: 
        libxmms.so.1 is needed by (installed) kdenetwork-3.2.0-0.1 
        libxmms.so.1 is needed by (installed) kdeaddons-3.2.0-0.1 
 
Some messing around with ldd reveals that the dependency is most 
likely caused by /usr/lib/kde3/mediacontrol_panelapplet.so, which is 
part of the Kicker mediacontrol applet.  This applet is probably 
rarely used, because players like juk install their own more compact 
controller into the system tray.  In any case, it would be nice to 
package this up separately. 
 
It would be nice to package this separately.  locate mediacontrol 
gives the following list of files on my system: 
 
/usr/share/locale/zh_CN/LC_MESSAGES/kcmmediacontrol.mo 
/usr/share/locale/zh_CN/LC_MESSAGES/mediacontrol.mo 
/usr/share/locale/zh_TW/LC_MESSAGES/kcmmediacontrol.mo 
/usr/share/locale/zh_TW/LC_MESSAGES/mediacontrol.mo 
/usr/share/apps/kicker/applets/mediacontrol.desktop 
/usr/share/apps/mediacontrol 
/usr/share/apps/mediacontrol/blueish 
/usr/share/apps/mediacontrol/blueish/next.png 
/usr/share/apps/mediacontrol/blueish/pause.png 
/usr/share/apps/mediacontrol/blueish/play.png 
/usr/share/apps/mediacontrol/blueish/prev.png 
/usr/share/apps/mediacontrol/blueish/stop.png 
/usr/share/apps/mediacontrol/default 
/usr/share/apps/mediacontrol/default/next.png 
/usr/share/apps/mediacontrol/default/pause.png 
/usr/share/apps/mediacontrol/default/play.png 
/usr/share/apps/mediacontrol/default/prev.png 
/usr/share/apps/mediacontrol/default/stop.png 
/usr/lib/kde3/mediacontrol_panelapplet.la 
/usr/lib/kde3/mediacontrol_panelapplet.so 
 
I believe these are all related to the media control panel applet.  
It should be possible to package it separately.
Comment 1 Keunwoo Lee 2004-02-13 18:10:26 EST
Incidentally, another reason that no KDE package should depend on 
xmms is that xmms no longer cooperates with arts, due to glib 
versioning problems.  So xmms is pretty useless under a standard KDE 
configuration. 
Comment 2 Ngo Than 2004-06-28 04:52:59 EDT
kdeaddon-3.2.3-2 has now subpackage kdeaddons-xmms. Thanks for your report

Note You need to log in before you can comment on or make changes to this bug.