Bug 115069 - freeglut RPMs are worthless, not compatible with existing GLUT
Summary: freeglut RPMs are worthless, not compatible with existing GLUT
Status: CLOSED DUPLICATE of bug 107228
Alias: None
Product: Fedora
Classification: Fedora
Component: freeglut (Show other bugs)
(Show other bugs)
Version: 1
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-02-06 03:37 UTC by Hugh
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:01:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hugh 2004-02-06 03:37:15 UTC
Description of problem:the freeglut and freeglut-devel RPMs shipped
with Fedora core are worthless as they are incompatible with standard
GLUT code.


How reproducible: Try to compile any program written for GLUT.

  
Actual results: massive number of compilation errors due to header
file GL/glut.h missing, as RPM has installed GL/freeglut.h


Expected results: GLUT programs that contain
#include <GL/glut.h>
ought to compile


Additional info:

Comment 1 Mike A. Harris 2004-02-06 05:27:25 UTC
Yes, I realize that.  For a detailed explanation of why this is so,
and what the plan for the future is with regards to glut and
freeglut, you can read bug #107228 for details.

Comment 2 Mike A. Harris 2004-02-06 05:27:53 UTC

*** This bug has been marked as a duplicate of 107228 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:01:06 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.