Bug 1150735 - rubygem-staypuft: Clicking on "Configure Networks" doesn't open the "Configure Networks" page - gets stuck.
Summary: rubygem-staypuft: Clicking on "Configure Networks" doesn't open the "Config...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: unspecified
Hardware: x86_64
OS: Unspecified
urgent
urgent
Target Milestone: z2
: Installer
Assignee: Mike Burns
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-08 20:30 UTC by Alexander Chuzhoy
Modified: 2014-11-04 17:03 UTC (History)
6 users (show)

Fixed In Version: ruby193-rubygem-staypuft-0.4.2-1.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-04 17:03:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1800 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Installer Bug Fix Advisory 2014-11-04 22:00:19 UTC

Description Alexander Chuzhoy 2014-10-08 20:30:52 UTC
rubygem-staypuft:  Clicking on  "Configure Networks" doesn't open the "Configure Networks" page - gets stack.


Environment:
openstack-puppet-modules-2014.1-22.1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-foreman-installer-2.0.28-1.el6ost.noarch
rhel-osp-installer-0.4.2-1.el6ost.noarch

Steps to reproduce:
1. Install rhel-osp-installer
2. Configure a deployment and assign hosts to it.
3. Go to the 'Hosts' tab of the deployment, then to "Assigned" subtab.
4. Select any host and click on the "Configure Networks" button.

Result:
The "Configure networks" page gets stack while opening.
See the following in the production.log:
Started GET "/deployments/1/interface_assignments?host_ids=5" for 10.10.48.205 at 2014-10-08 16:26:48 -0400
Processing by Staypuft::InterfaceAssignmentsController#index as */*
  Parameters: {"host_ids"=>"5", "deployment_id"=>"1"}
  Rendered /opt/rh/ruby193/root/usr/share/gems/gems/staypuft-0.4.1/app/views/staypuft/subnets/_subnet_pull.html.erb (2.4ms)
  Rendered /opt/rh/ruby193/root/usr/share/gems/gems/staypuft-0.4.1/app/views/staypuft/subnets/_subnet_pull.html.erb (2.3ms)
  Rendered /opt/rh/ruby193/root/usr/share/gems/gems/staypuft-0.4.1/app/views/staypuft/subnets/_subnet_pull.html.erb (2.9ms)
  Rendered /opt/rh/ruby193/root/usr/share/gems/gems/staypuft-0.4.1/app/views/staypuft/interfaces/_drop_zone.html.erb (8.4ms)
  Rendered /opt/rh/ruby193/root/usr/share/gems/gems/staypuft-0.4.1/app/views/staypuft/interface_assignments/_interfaces.html.erb (11.7ms)
  Rendered /opt/rh/ruby193/root/usr/share/gems/gems/staypuft-0.4.1/app/views/staypuft/interface_assignments/_nics_assignment.html.erb (24.9ms)
  Rendered /opt/rh/ruby193/root/usr/share/gems/gems/staypuft-0.4.1/app/views/staypuft/interface_assignments/index.html.erb (30.3ms)
Operation FAILED: undefined method `model_name' for Hash:Class


Expect result:
The "Configure networks" page should open and let assign roles to configured networks.

Comment 1 Marek Hulan 2014-10-09 14:26:21 UTC
Fix is in foreman upstream https://github.com/theforeman/foreman/pull/1810

Comment 4 Alexander Chuzhoy 2014-10-14 14:58:47 UTC
Verified:
rhel-osp-installer-0.4.2-1.el6ost.noarch                
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-puppet-modules-2014.1-23.el6ost.noarch                
openstack-foreman-installer-2.0.29-1.el6ost.noarch  


The reported issue doesn't reproduce.

Comment 6 Mike Burns 2014-10-24 13:39:29 UTC
internal only bug, found by QE, fixed before anyone external would see it

Comment 8 errata-xmlrpc 2014-11-04 17:03:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1800.html


Note You need to log in before you can comment on or make changes to this bug.