Bug 1150872 - FSError: mount failed: 32
Summary: FSError: mount failed: 32
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-blivet
Version: 21
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: David Shea
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1147178 1156370 (view as bug list)
Depends On:
Blocks: ZedoraTracker
TreeView+ depends on / blocked
 
Reported: 2014-10-09 06:01 UTC by Ed Greshko
Modified: 2014-11-12 22:29 UTC (History)
11 users (show)

Fixed In Version: anaconda-21.48.10-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-20 23:02:09 UTC
Type: Bug


Attachments (Terms of Use)
anaconda-tb (647.87 KB, text/plain)
2014-10-09 20:38 UTC, David Shea
no flags Details

Description Ed Greshko 2014-10-09 06:01:52 UTC
Description of problem: Net install crashes if BTRFS is selected


Version-Release number of selected component (if applicable): anaconda 21.48.8-1 (F21 Beta TC2)


How reproducible: Try to install F21 Beta TC2 and selecting BTRFS with auto partitioning


Steps to Reproduce:
1.
2.
3.

Actual results:

anaconda 21.48.8-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/blivet/formats/fs.py", line 593, in mount
    raise FSError("mount failed: %s" % rc)
  File "/usr/lib/python2.7/site-packages/blivet/formats/fs.py", line 1114, in setu
p
    return self.mount(**kwargs)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 2756, in mountF
ilesystems
    chroot=rootPath)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 1790, in mountF
ilesystems
    readOnly=readOnly, skipRoot=skipRoot)
  File "/usr/lib/python2.7/site-packages/blivet/__init__.py", line 223, in turnOnF
ilesystems
    storage.mountFilesystems()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 178, in do
Install
    turnOnFilesystems(storage, mountOnly=flags.flags.dirInstall)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 227, in ru
n
    threading.Thread.run(self, *args, **kwargs)
FSError: mount failed: 32


Expected results:


Additional info:

The log tar can be downloaded from here...

https://drive.google.com/file/d/0B2H9v1dYNcvpZEhhT3BxaTlLMVk/view?usp=sharing

Comment 1 David Shea 2014-10-09 20:38:44 UTC
Created attachment 945436 [details]
anaconda-tb

Next time, please attach the log files to the bug, or use the bug reporting tool within anaconda to create the bug with the attachments.

Comment 2 Ed Greshko 2014-10-09 21:00:06 UTC
I was unable to use the bug reporting tool since it found it to be a dup of a closed bugzilla!  Otherwise, that is what I would have done.  Also, if bugzilla didn't have such a small limit on the size of an attachment, that would have made things easier as well since there was a total of 41 files produced by the anaconda tool!

I'm sorry to have done it the way I did, but the current state of things didn't help make it easy on the reporter.

Comment 3 David Shea 2014-10-10 12:58:36 UTC
The "None" in mount -t btrfs -o None,subvol=root was the problem, fix pushed as 1aede5f41cf7cef86ed0b9a0942f47d0288f6fa7

Comment 4 Fedora Update System 2014-10-15 13:15:47 UTC
anaconda-21.48.10-1.fc21, pykickstart-1.99.63-2.fc21, python-blivet-0.61.5-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/pykickstart-1.99.63-2.fc21,python-blivet-0.61.5-1.fc21,anaconda-21.48.10-1.fc21

Comment 5 Fedora Update System 2014-10-16 17:18:45 UTC
Package anaconda-21.48.10-1.fc21, pykickstart-1.99.63-2.fc21, python-blivet-0.61.5-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-21.48.10-1.fc21 pykickstart-1.99.63-2.fc21 python-blivet-0.61.5-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-12944/pykickstart-1.99.63-2.fc21,python-blivet-0.61.5-1.fc21,anaconda-21.48.10-1.fc21
then log in and leave karma (feedback).

Comment 6 Antoni Segura Puimedon 2014-10-20 10:19:41 UTC
*** Bug 1147178 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2014-10-20 23:02:09 UTC
anaconda-21.48.10-1.fc21, pykickstart-1.99.63-2.fc21, python-blivet-0.61.5-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 David Shea 2014-11-12 22:29:47 UTC
*** Bug 1156370 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.