Bug 115089 - Unable to setup X with Intel Corp. 82845G/GL [Brookdale-G] Chipset
Unable to setup X with Intel Corp. 82845G/GL [Brookdale-G] Chipset
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-06 10:26 EST by Ajay Gautam
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-06 11:19:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The X Config file (3.09 KB, text/plain)
2004-02-06 10:29 EST, Ajay Gautam
no flags Details
X Startup log file (2.57 KB, text/plain)
2004-02-06 10:29 EST, Ajay Gautam
no flags Details
strace -ff -o xfree XFree86 -configure (59.31 KB, text/plain)
2004-02-06 10:30 EST, Ajay Gautam
no flags Details

  None (edit)
Description Ajay Gautam 2004-02-06 10:26:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a)
Gecko/20040125

Description of problem:
Hello.

I am trying to setup Fedora on a space office machine (IBM Netvista
8307-KSU) to prove that a Linux based office machine is possible.
Unfortunately, I am stuck at the install phase with this machine.

It seems that the Display chipset does not work well with Linux. I
have tried i810, vesa drivers that pre-installed. I have also tried
i830 driver from intel's website. Nothing works. IBM does not have
linux drivers on their website.

X -configure fails too. I am attaching the latest X log file,
XF86Config file. Please let me know if any more info is needed. Here
is more info about my setup:

lspci -vvv:
******************
00:02.0 VGA compatible controller: Intel Corp. 82845G/GL [Brookdale-G]
Chipset Integrated Graphics Device (rev 01) (prog
-if 00 [VGA])
        Subsystem: IBM: Unknown device 0267
        Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop-
ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Interrupt: pin A routed to IRQ 11
        Region 0: Memory at 88000000 (32-bit, prefetchable) [size=128M]
        Region 1: Memory at 80000000 (32-bit, non-prefetchable)
[size=512K]
        Capabilities: [d0] Power Management version 1
                Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
******************

X -version
******************
XFree86 Version 4.3.0 (Fedora Core 1: 4.3.0-42)
Release Date: 15 August 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.4.21-2.ELsmp i686 [ELF]
OS Kernel: Linux version 2.4.22-1.2115.nptl
(bhcompile@daffy.perf.redhat.com) (gcc version 3.2.3 20030422 (Red Hat
Linux 3.2.3-6)) #1 Wed Oct 29 15:42:51 EST 2003
******************

gcc -dumpversion: 3.3.2

I read somewhere that agpgart should be compiled in kernel, so I tried
that and failed. Copied configs/kernel-2.4.22-i686.config to .config,
make menuconfig, and select agpgart as built in, make dep clean
bzImage modules modules_install. Fails at:
******************
ld -m elf_i386 -T
/usr/src/linux-2.4.22-1.2115.nptl/arch/i386/vmlinux.lds -e stext
arch/i386/kernel/head.o arch/i386/kernel/init_task.o init/main.o
init/version.o init/do_mounts.o --start-group
arch/i386/kernel/kernel.o arch/i386/mm/mm.o kernel/kernel.o mm/mm.o
fs/fs.o ipc/ipc.o  drivers/acpi/acpi.o drivers/cpufreq/cpufreq.o
drivers/char/char.o drivers/block/block.o drivers/misc/misc.o
drivers/net/net.o drivers/char/agp/agp.o drivers/char/drm/drm.o
drivers/net/fc/fc.o drivers/net/appletalk/appletalk.o
drivers/net/tokenring/tr.o drivers/net/wan/wan.o drivers/atm/atm.o
drivers/ide/idedriver.o drivers/cdrom/driver.o drivers/pci/driver.o
drivers/net/pcmcia/pcmcia_net.o drivers/net/wireless/wireless_net.o
drivers/pnp/pnp.o drivers/video/video.o drivers/media/media.o
drivers/md/mddev.o drivers/isdn/vmlinux-obj.o crypto/crypto.o
net/network.o /usr/src/linux-2.4.22-1.2115.nptl/arch/i386/lib/lib.a
/usr/src/linux-2.4.22-1.2115.nptl/lib/lib.a
/usr/src/linux-2.4.22-1.2115.nptl/arch/i386/lib/lib.a --end-group -o
.tmp_vmlinux1
kernel/kernel.o(.text+0xfc3): In function `schedule':
: undefined reference to `active_load_balance'
make[1]: *** [kallsyms] Error 1
make[1]: Leaving directory `/usr/src/linux-2.4.22-1.2115.nptl'
make: *** [vmlinux] Error 2
******************

Thanks

Ajay

Version-Release number of selected component (if applicable):
XFree86 Version 4.3.0 (Fedora Core 1: 4.3.0-42)

How reproducible:
Always

Steps to Reproduce:
1. Start XWindows

Additional info:
Comment 1 Ajay Gautam 2004-02-06 10:29:21 EST
Created attachment 97512 [details]
The X Config file
Comment 2 Ajay Gautam 2004-02-06 10:29:43 EST
Created attachment 97513 [details]
X Startup log file
Comment 3 Ajay Gautam 2004-02-06 10:30:29 EST
Created attachment 97514 [details]
strace -ff -o xfree XFree86 -configure
Comment 4 Mike A. Harris 2004-02-06 11:19:36 EST
This is not a bug.  I see two problems here:

1) You have tried to use an unsupported configuration mechanism,
   namely running "X -configure" plus hand editing the config file
   incorrectly and ending up with a totally bogus configuration

2) Your installation seems like it might be broken due to the first
   server module barfing.  Often caused by disk corruption or other
   problems.

The Intel i845 works fine on FC1, however systems which have broken
BIOS's will limit the video memory to 1Mb, and XFree86 can not
do anything about that.  (See other bug reports in bugzilla or
search google for "i845 stolen memory" problem for more details).

What you need to do now, is remove any 3rd party drivers, reinstall
the Red Hat supplied drivers, and use the Red Hat supplied binary
kernel.  Then update your system to the latest Red Hat supplied
updates, and run our sole supported X configuration tool:

    redhat-config-xfree86 --reconfig

Once that is done, you should have a working X configuration,
unless of course there is some other problem such as #2 above.
If you do continue to have a problem after all of this, then my
suggestion is to subscribe to the XFree86@xfree86.org mailing
list and post the problem there, and seek technical assistance.
It's also possible your specific system has some problem such
as an unsupported agp chipset or something.

Either way, this very much does not look like a bug.


Comment 5 Ajay Gautam 2004-02-06 14:29:45 EST
Thanks for pointing me in the right direction. I wasn't sure if this
was a module bug or a config problem. The problem is now resolved. You
were right, it was a BIOS issue.

Somehow, I was under the impression that Linux does not deal with the
BIOS, apparentaly not...

Thanks once again

ajay

Note You need to log in before you can comment on or make changes to this bug.