Bug 1150930 - qemu-kvm-rhev-2.1.2-1 couldn't support memory hot-plug
Summary: qemu-kvm-rhev-2.1.2-1 couldn't support memory hot-plug
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.1
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Igor Mammedov
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-09 08:29 UTC by Lin Chen
Modified: 2014-12-09 00:38 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-21 10:50:10 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Lin Chen 2014-10-09 08:29:59 UTC
Description of problem:
qemu-kvm-rhev-2.1.2-1 couldn't support memory hot-plug with command: 
(qemu)object_add memory-backend-ram,id=mem1,size=1G
(qemu)device_add pc-dimm,id=dimm1,memdev=mem1
then get error message as follows:
 'DIMM property node has value 0' which exceeds the number of numa nodes: 0
  Device 'pc-dimm' could not be initialized

But it is successful inside qemu-kvm-rhev-2.1.0-4


Version-Release number of selected component (if applicable):
inside host:
    rpm -qa|grep qemu
    qemu-kvm-rhev-2.1.2-1.el7.x86_64
    uname -r
    3.10.0-184.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.boot qemu with command:
/usr/libexec/qemu-kvm -name RHEL-Server-7.0-64 -m 4G,slots=4,maxmem=8G -smp 4,cores=2,threads=2,sockets=1,maxcpus=160 -monitor stdio

2.do memory hot-plug inside qemu:
(qemu)object_add memory-backend-ram,id=mem1,size=1G
(qemu)device_add pc-dimm,id=dimm1,memdev=mem1


Actual results:
wouldn't do memory hot-plug and get error message like this:
 'DIMM property node has value 0' which exceeds the number of numa nodes: 0
  Device 'pc-dimm' could not be initialized


Expected results:
do memory hot-plug successfully and there is no error message

Additional info:

Comment 4 Igor Mammedov 2014-11-21 10:50:10 UTC

*** This bug has been marked as a duplicate of bug 1163735 ***

Comment 6 Igor Mammedov 2014-11-24 10:21:00 UTC
I've tried to find this one first but failed, so I created a new one for patch submission.

Comment 8 juzhang 2014-12-09 00:38:56 UTC
Update this bz as current release according to comment7.


Note You need to log in before you can comment on or make changes to this bug.