Bug 1151054 - 'dhcrelay -6 -l <nic1> -u <nic2>' does not work
Summary: 'dhcrelay -6 -l <nic1> -u <nic2>' does not work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: dhcp
Version: 6.6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Jiri Popelka
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-09 13:52 UTC by Jiri Popelka
Modified: 2015-07-22 05:39 UTC (History)
4 users (show)

Fixed In Version: dhcp-4.1.1-45.P1.el6
Doc Type: Bug Fix
Doc Text:
Cause When running DHCPv6 relay agent and 'lower' interface is specified ('-l') on command line before 'upper' interface ('-u'). Consequence Relaying of messages does not work. Fix Problem in one of our patches was identified and fixed. Result DHCPv6 relay agent properly relays messages.
Clone Of:
Environment:
Last Closed: 2015-07-22 05:39:49 UTC
Target Upstream Version:


Attachments (Terms of Use)
upstream patch for bug #1001742 (10.02 KB, patch)
2014-10-09 13:52 UTC, Jiri Popelka
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1258 normal SHIPPED_LIVE dhcp bug fix and enhancement update 2015-07-20 17:49:55 UTC

Description Jiri Popelka 2014-10-09 13:52:35 UTC
Created attachment 945313 [details]
upstream patch for bug #1001742

Description of problem:
Patch [1] that we use to fix bug #1001742 breaks dhcrelay (dhcp relay agent daemon) for IPv6.
When the 'lower' interface is specified ('-l') on command line before 'upper' interface ('-u') the relaying of messages does not work.
Example:
$ dhcrelay -d -6 -I -l eth0 -u eth1

[1] http://pkgs.devel.redhat.com/cgit/rpms/dhcp/tree/dhcp-4.1.1-P1-ipv6-bind-to-interface.patch?h=rhel-6.6

Version-Release number of selected component (if applicable):
dhcp-4.1.1-43.P1.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. [relay machine]
  $ dhcrelay -d -6 -I -l eth0 -u eth1
2. [relay machine]
  $ wireshark
3. [client machine]
  $ dhclient -d -6 -S ethx (ethx is connected to the same link as dhcrelay's 'lower' interface)

Actual results:
no Relay-Forw message

Expected results:
Relay-Forw message sent to ff05::1:3

Additional info:
dhcrelay -d -6 -I -u eth1 -l eth0
still works

clone of bug #1151039 (RHEL-7)

Comment 2 Jiri Popelka 2014-10-10 09:45:30 UTC
Lowering both severity/priority as the IPv6 version of dhcrelay is probably not much used and there's a workaround (changing order of command-line arguments).

Comment 8 errata-xmlrpc 2015-07-22 05:39:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1258.html


Note You need to log in before you can comment on or make changes to this bug.