Bug 1151156 - rubygem-staypuft: Clicking on 'Access all details' button after a successful deployment - get the following in Controllers IPs secton: "192.168.0.6 what subnet type here?"
Summary: rubygem-staypuft: Clicking on 'Access all details' button after a successful...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rubygem-staypuft
Version: Foreman (RHEL 6)
Hardware: x86_64
OS: Linux
high
low
Target Milestone: z2
: Installer
Assignee: Scott Seago
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-09 16:40 UTC by Alexander Chuzhoy
Modified: 2014-11-04 17:03 UTC (History)
5 users (show)

Fixed In Version: ruby193-rubygem-staypuft-0.4.5-1.el6ost
Doc Type: Bug Fix
Doc Text:
After a successful deployment, clicking the 'Access all details' button will now also display IP addresses on the Management, Public API, and Admin API networks.
Clone Of:
Environment:
Last Closed: 2014-11-04 17:03:17 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1800 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Installer Bug Fix Advisory 2014-11-04 22:00:19 UTC

Description Alexander Chuzhoy 2014-10-09 16:40:00 UTC
rubygem-staypuft:  Clicking on 'Access all details' button after a successful deployment - get the following in Controllers IPs secton: "192.168.0.6 what subnet type here?"

Environment:
openstack-puppet-modules-2014.1-22.1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-foreman-installer-2.0.28-1.el6ost.noarch
rhel-osp-installer-0.4.2-1.el6ost.noarch


Steps to reproduce:
1. install rhel-osp-installer.
2. Configure nonHA neutron deployment.
3. Once the deployment completes successfully - click on the "Access all details" button.

Result:
Get the following text in the Controllers IPs section: "192.168.0.6 what subnet type here?"

Expected result:
No questions should be there

Comment 1 Scott Seago 2014-10-09 16:49:22 UTC
THis looks like something that was intended as a "TODO" or "FIXME" comment but ended up in the actual rendered text instead. Right now, for HA this page shows all VIPs (so on admin, public, and private networks, but about 33 total). For non-HA we're only showing the single 'Management' network IP.

We should probably change the latter to showing IP addresses on the three API networks (Management, Public API, Admin API), with labels (in addition to removing the question/comment text).

Comment 2 Scott Seago 2014-10-10 14:22:19 UTC
Fix is in this PR: https://github.com/theforeman/staypuft/pull/344

Fix is as described in comment 1

Comment 3 Scott Seago 2014-10-10 20:06:21 UTC
Pushed to master; puddle later today.

Comment 5 Alexander Chuzhoy 2014-10-14 15:38:04 UTC
Verified:
rhel-osp-installer-0.4.2-1.el6ost.noarch                
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-puppet-modules-2014.1-23.el6ost.noarch                
openstack-foreman-installer-2.0.29-1.el6ost.noarch  


The reported issue doesn't reproduce.

Comment 10 errata-xmlrpc 2014-11-04 17:03:17 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1800.html


Note You need to log in before you can comment on or make changes to this bug.