Bug 115147 - M$ intellimouse wheel does not scroll up in mozilla.
M$ intellimouse wheel does not scroll up in mozilla.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-06 17:32 EST by Tom Diehl
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: fc5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-28 17:05:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Diehl 2004-02-06 17:32:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040115

Description of problem:
When I use the mouse wheel to scroll down it works ok. If I try to
scroll up it does not work.

Version-Release number of selected component (if applicable):
mozilla-1.6-0

How reproducible:
Always

Steps to Reproduce:
1.Use the wheel on the mouse to scroll down a page.
2.Try to use the wheel to scroll back up
3.
    

Actual Results:  when I try to scroll up I get the menu I would get if
I right clicked on the desktop.

Expected Results:  It should scroll up

Additional info:

This mouse works fine with FC1 and previous versions of RHL.
Comment 1 Tom Diehl 2004-02-06 17:34:39 EST
One additional note: The scroll wheel appears to work normally in
things like konsole. I have only noticed this behavior in mozilla.
Comment 2 Johnny Hughes 2004-02-22 10:30:48 EST
I have the exact same problem ... but for me (in GNOME) it happens in
Mozilla, on the desktop and in all other applications I tried in Gnome
(gedit, gterminal, etc.)

Also, it isn't just a right click ... it is a right click followed by
a center button click.

I have a logitech scroll optical mouse.

I have noticed the exact same behavior in Mandrake 10 RC1 and Debian
SID with a 2.6.x kernel.

Here is the applicable portion of my XF86Config file:

        Identifier  "DevInputMice"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/input/mouse0"
        Option      "ZAxisMapping" "4 5"
        Option      "Emulate3Buttons" "no"

One other thing that might be applicable ... my mouse is a USB mouse
that connects via a KVM switch.
Comment 3 Johnny Hughes 2004-02-22 11:05:31 EST
More information ....

If the mouse is connected directly to the PS2 port ... and not through
the KVM switch, the mouse works correctly.

I currently have Fedora Core 1.90 kernel-2.6.3-1.97.

On any 2.4.x kernel, the mouse works correctly reguardless of whether
it is connected via the kvm switch or not.

My original switch is a Belkin Omniview SE 4-Port KVM switch.

I observe the same indications if using a Cybex AutoView Commander
8-Port KVM Switch...
Comment 4 Johnny Hughes 2004-02-22 11:43:54 EST
More information and testing:

The problem is definately related to the KVM switch .....

When connected through the KVM switch, if the system is started while
on it's channel and the channel is never changed...the mouse works
like it is supposed to (in both Gnome and KDE and with all applications).

If I switch to another PC and then switch back to the Fedora Core
Machine via the KVM switch, that is when the error happens.

I switched with the mouse functioning properly in KDE and in Gnome.  

I had a problem in both cases...when the prolem happens in GNOME, it
is how I posted before ... a right click followed by a center button
click for a scroll up of the mouse wheel ... when the problem happens
is KDE it is just a right click on the scroll up (not followed by a
center center click)

Unpluging the mouse from the KVM switch (and replugging it in) solves
the problem (ie removing power from the mouse)...but unpluging the KVM
switch mouse cable from the computer (with the mouse still recieving
power from the switch) does not fix the problem.

It made no difference wheter I used the CYBEX Autocommander 8 port or
the Belkin OmniView 4 port switch ... the results were identical and
always reproduceable (I did each test 4 times on each switch (on both
gnome and KDE).
Comment 5 Christopher Blizzard 2004-03-05 15:26:59 EST
I have a belken as well.  I have this problem at home, and it's the
KVM - there's nothing that I know of that we can do.  Alan had some
insight at one point into this, adding in case he has a comment but
I'm invoking my first strike right and closing this bug.
Comment 6 Tom Diehl 2004-03-05 16:08:17 EST
But I do not have a belkin KVM, and I reported the bug originally!!
Ignore it if you will but...

Also FWIW FC1 works just fine on this machine. IMO this has something
to do with FC2. I just wish I knew what. Besides I thought 2.6 was
supposed to work with a kvm.
Comment 7 Alan Cox 2004-03-05 17:08:22 EST
There are two problems here

#1 the KVM case ("not supported") - Seems Belkin KVM doesn't speak
enough of the extended PS/2 protocol to reconfigure the mouse. I guess
its XFree86's fault as it should be able to interpret the "reconnect"
codes sent. But its not a supported setup

#2 Is the Tom Diehl one and looks like it may be a kernel or X thing.
Tom can you have a look at the wheel behaviour with "xev" and see what
event messages it prints when you use the wheel ?

Comment 8 Johnny Hughes 2004-03-06 21:46:52 EST
OK ... I found a fix to my problem (I was using a Gentoo 2.6.3 kernel
with exactly the same problem...

I added this to the end of my kernel line in grub.conf:

psmouse.proto="ExplorerPS/2"

I also changed the following line in my /etc/X11/XF86Config file:

Option      "Protocol" "IMPS/2"

to

Option      "Protocol" "ExplorerPS/2"

Now, I can change channels on the KVM switch and everything works
correctly.
Comment 9 Homer J 2004-05-15 00:31:53 EDT
FWIW just changing my xorg.conf to use ExplorerPS/2 seems to have
resolved this problem for me.

I'm using a Logitech optical wireless mouse through an IOgear 4-port
KVM.  This same config worked fine w/ IMPS/2 under FC1.
Comment 10 Kevin Tambascio 2004-11-10 07:57:33 EST
I also saw the same result as comment #9.  I'm running Fedora Core 3,
and changed xorg.conf to use "ExplorerPS/2", CTRL+ALT+BACKSPACE, log
in to KDE, everything works normally now.  I'm using a Linksys 4-port KVM.
Comment 11 Jpwne 2005-03-12 10:15:16 EST
Similar to #4 I get rid of the problem by unplugging the mouse. After
that I can switch back and forth with no mousewheel or nav-button
issues, but it woul dbe nice to see a solution that works from
startup. Running 2.6 Gentoo.
Comment 12 Sami Farin 2005-12-09 19:35:35 EST
xorg upgrade 6.8.2 to 6.99.99.902 brought this change:
buttons 6 and 7 now do the same thing than 4 and 5 in 6.8.2, and vice versa.
however, running commands
xmodmap -e "pointer = 1 2 3 6 7 4 5"
or
xmodmap -e "pointer = 1 2 3 4 5 6 7"
does not make any diff!

what gives?

# rpm -qf /usr/bin/Xorg 
xorg-x11-server-Xorg-0.99.3-9
# rpm -qf /usr/bin/xmodmap 
xorg-x11-server-utils-0.99.2-6



    Identifier  "IntelliMouse"
    Driver      "mouse"
    Option "Protocol"       "ExplorerPS/2" 
    Option "Device"         "/dev/input/mice"
    Option "Buttons"        "7"
    Option "ZAxisMapping"   "6 7"
#    Option "SendCoreEvents" "true"
Comment 13 Sami Farin 2005-12-14 09:49:29 EST
I tried also evdev, did not work.
My problem seems to be fixed in 7.0.0 RC 3 (Fedora ships 7.0.0 RC 2).
https://bugs.freedesktop.org/show_bug.cgi?id=4212
Comment 14 John Thacker 2006-10-28 17:05:46 EDT
The original problem was fixed.  The last two comments are about a slightly
different from on either FC4 or a test release of FC5.  This should be fixed in
FC5 and FC6, which are the only supported versions, and it does not seem to be a
security bug.  Closing

Note You need to log in before you can comment on or make changes to this bug.