Bug 1151559 - User interface freezes when entering space character in Xfig
Summary: User interface freezes when entering space character in Xfig
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-qxl
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Marc-Andre Lureau
QA Contact: SPICE QE bug list
URL:
Whiteboard:
Depends On: 1151363
Blocks: 1221909
TreeView+ depends on / blocked
 
Reported: 2014-10-10 17:12 UTC by Marc-Andre Lureau
Modified: 2015-07-22 07:31 UTC (History)
20 users (show)

Fixed In Version: xorg-x11-drv-qxl-0.1.1-16.el6
Doc Type: Bug Fix
Doc Text:
Cause: bug in the way the qxl driver handles unexpected drawing commands Consequence: the display would freeze when entering a space character in the Xfig application Fix: Make sure the QXL driver does not misbehave when such a situation occurs Result: no more display freeze
Clone Of: 1151363
: 1221909 (view as bug list)
Environment:
Last Closed: 2015-07-22 07:31:51 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1399 normal SHIPPED_LIVE xorg-x11-drv-qxl bug fix update 2015-07-20 18:07:22 UTC

Description Marc-Andre Lureau 2014-10-10 17:12:55 UTC
+++ This bug was initially created as a clone of Bug #1151363 +++

--- Additional comment from Alon Levy on 2014-10-10 11:38:55 EDT ---

You can change the qemu condition to be nicer to old drivers, and (to avoid requiring upgrades of qemu) fix the driver not to do an update area in this case.

Comment 2 Marc-Andre Lureau 2014-10-12 13:24:44 UTC
sent patches:
http://lists.freedesktop.org/archives/spice-devel/2014-October/017598.html

Comment 6 errata-xmlrpc 2015-07-22 07:31:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1399.html


Note You need to log in before you can comment on or make changes to this bug.