Bug 1151571 - Alpha installer unable to add bootloader EFI entry on AArch64
Summary: Alpha installer unable to add bootloader EFI entry on AArch64
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: efibootmgr
Version: 21
Hardware: aarch64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Jones
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ARM64, F-ExcludeArch-aarch64
TreeView+ depends on / blocked
 
Reported: 2014-10-10 17:35 UTC by Marcin Juszkiewicz
Modified: 2014-12-03 11:55 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-03 11:55:51 UTC


Attachments (Terms of Use)
screenshot (with messages partially in Polish) (95.26 KB, image/jpeg)
2014-10-10 17:35 UTC, Marcin Juszkiewicz
no flags Details
anaconda.log (21.76 KB, text/plain)
2014-10-13 07:09 UTC, Marcin Juszkiewicz
no flags Details
journal.log (825.91 KB, text/plain)
2014-10-13 07:09 UTC, Marcin Juszkiewicz
no flags Details
packaging.log (216.58 KB, text/plain)
2014-10-13 07:10 UTC, Marcin Juszkiewicz
no flags Details
program.log (29.97 KB, text/plain)
2014-10-13 07:11 UTC, Marcin Juszkiewicz
no flags Details
storage.log (142.80 KB, text/plain)
2014-10-13 07:11 UTC, Marcin Juszkiewicz
no flags Details
syslog (54.64 KB, text/plain)
2014-10-13 07:11 UTC, Marcin Juszkiewicz
no flags Details
storage log (90.85 KB, text/plain)
2014-11-28 21:11 UTC, Paul Whalen
no flags Details
program log (29.63 KB, text/plain)
2014-11-28 21:11 UTC, Paul Whalen
no flags Details
packaging (133.87 KB, text/plain)
2014-11-28 21:12 UTC, Paul Whalen
no flags Details
anaconda log (5.76 KB, text/plain)
2014-11-28 21:12 UTC, Paul Whalen
no flags Details

Description Marcin Juszkiewicz 2014-10-10 17:35:47 UTC
Created attachment 945759 [details]
screenshot (with messages partially in Polish)

Description of problem:

Installation stopped on bootloader installation.

Version-Release number of selected component (if applicable):

F21 alpha from http://arm.koji.fedoraproject.org/compose/21_Alpha_RC1/Server/aarch64/iso/

How reproducible:

always

Steps to Reproduce:
1. do an installation of Fedora 21 on APM Mustang using DVD

Actual results:

fails to install bootloader

Expected results:

bootloader is installed and system boots

Additional info:

TC1 image worked fine

Comment 1 Marcin Juszkiewicz 2014-10-10 17:42:47 UTC
Grub is present in /boot/efi partition just there is no entry in EFI to boot it.

UEFI Interactive Shell v2.0
EDK II
UEFI v2.40 (X-Gene Mustang Board EFI Aug 21 2014 13:43:15, 0x00000000)
Mapping table
      FS0: Alias(s):HD9b0a1:;BLK1:
          PciRoot(0x7)/Pci(0x0,0x0)/Sata(0x1,0x0,0x0)/HD(1,GPT,991DEAC7-21D7-4FD8-A072-0CFF9D3351BB,0x800,0x64000)
      FS1: Alias(s):HD10a0b:;BLK5:
          PciRoot(0x8)/Pci(0x0,0x0)/USB(0x0,0x0)/HD(1,GPT,07A2CC65-FF01-48F7-9E54-CCB05A154A1D,0x800,0x3B801)
     BLK7: Alias(s):
          VenHw(6C9CEEF0-A406-11E3-A5E2-0800200C9A66)
     BLK6: Alias(s):
          VenHw(02118005-9DA7-443A-92D5-781F022AEDBB)
     BLK9: Alias(s):
          VenHw(F40A3869-92C4-4275-8501-4491A1A20C19)
     BLK8: Alias(s):
          VenHw(B225ED30-6DFD-43A9-BF6B-5753358F2F70)
     BLK0: Alias(s):
          PciRoot(0x7)/Pci(0x0,0x0)/Sata(0x1,0x0,0x0)
     BLK2: Alias(s):
          PciRoot(0x7)/Pci(0x0,0x0)/Sata(0x1,0x0,0x0)/HD(2,GPT,DE4A06FE-FBDE-4065-AF19-993793AD61DE,0x64800,0xFA000)
     BLK3: Alias(s):
          PciRoot(0x7)/Pci(0x0,0x0)/Sata(0x1,0x0,0x0)/HD(3,GPT,241871BB-3515-432E-A9B8-8A70D8E46020,0x15E800,0x252D0000)
     BLK4: Alias(s):
          PciRoot(0x8)/Pci(0x0,0x0)/USB(0x0,0x0)
FS0:\EFI\fedora\> \EFI\fedora\ startup.nsh or any other key to continue.
10/10/2014  17:14 <DIR>         4,096  .FI
10/10/2014  17:14 <DIR>         4,096  ..
10/10/2014  17:14 <DIR>         4,096  fonts
10/10/2014  17:37               3,915  grub.cfg
09/02/2014  10:17             801,792  grubaa64.efi
          2 File(s)     805,707 bytes
          3 Dir(s)

Comment 2 David Shea 2014-10-10 17:45:26 UTC
What does the screenshot you attached have to do with the bootloader? That looks like a dependency problem, and thus a problem with the repository. Please attach the log files from the install to this bug as individual, text/plain attachments.

Comment 3 Marcin Juszkiewicz 2014-10-10 17:52:56 UTC
Hmmm. When booted system I got:

--------------------------------------------------------------
[root@localhost hrw]# efibootmgr -v
Timeout: 2 seconds
Boot0000* Fedora        HD(1,800,64000,991deac7-21d7-4fd8-a072-0cff9d3351bb)File(\EFI\fedora\grubaa64.efi)
--------------------------------------------------------------

But in UEFI I do not see Fedora boot option:

--------------------------------------------------------------
TianoCore 1.1-rh-0.12-1 UEFI 2.4.0 Aug 21 2014 13:35:29
CPU: APM ARM 64-bit Potenza 2400MHz PCP 2400MHz
     32 KB ICACHE, 32 KB DCACHE
     SOC 2000MHz IOBAXI 400MHz AXI 250MHz AHB 200MHz GFC 125MHz
Board: X-Gene Mustang Board
The default boot selection will start in   1 second 
Attempting PXE boot on MAC: 00:01:73:02:0B:73


InstallProtocolInterface: 245DCA21-FB7B-11D3-8F01-00A0C969723B 43FE9600E0
.PXE-E18: Server response timeout.
-----------------------
Global FDT Config
        - VenHw(F40A3869-92C4-4275-8501-4491A1A20C19)/\mustang.dtb
-----------------------
[a] Boot Manager
[b] Shell
[c] Reboot
[d] Shutdown
Start: 
--------------------------------------------------------------

Comment 4 Marcin Juszkiewicz 2014-10-10 17:53:41 UTC
(In reply to David Shea from comment #2)
> What does the screenshot you attached have to do with the bootloader? That
> looks like a dependency problem, and thus a problem with the repository.
> Please attach the log files from the install to this bug as individual,
> text/plain attachments.

Tell me where those logs are on installed system (or how to get them during installation) and I will provide them on Monday.

Comment 5 David Shea 2014-10-10 17:55:29 UTC
They are copied to /var/log/anaconda on the installed system. During installation they are available in /tmp.

Comment 6 Marcin Juszkiewicz 2014-10-13 07:09:14 UTC
Created attachment 946254 [details]
anaconda.log

Comment 7 Marcin Juszkiewicz 2014-10-13 07:09:59 UTC
Created attachment 946255 [details]
journal.log

Comment 8 Marcin Juszkiewicz 2014-10-13 07:10:39 UTC
Created attachment 946256 [details]
packaging.log

Comment 9 Marcin Juszkiewicz 2014-10-13 07:11:03 UTC
Created attachment 946257 [details]
program.log

Comment 10 Marcin Juszkiewicz 2014-10-13 07:11:39 UTC
Created attachment 946258 [details]
storage.log

Comment 11 Marcin Juszkiewicz 2014-10-13 07:11:58 UTC
Created attachment 946259 [details]
syslog

Comment 12 Marcin Juszkiewicz 2014-10-13 09:45:18 UTC
https://bugs.linaro.org/show_bug.cgi?id=101 can be useful too.

Comment 13 Laszlo Ersek 2014-10-13 12:13:55 UTC
anaconda.log says

19:21:11,553 ERR anaconda: bootloader.write failed: failed to set new efi boot target. This is most likely a kernel bug.

(Also, please switch back to English messages for reproducing / reporting bugs.)

Then, program.log says

19:21:01,156 INFO program: Running... efibootmgr -c -w -L Fedora -d /dev/sda -p 1 -l \EFI\fedora\grubaa64.efi
19:21:05,541 DEBUG program: Return code: 1

More information is necessary from efibootmgr (error message eg.)

Comment 14 Marcin Juszkiewicz 2014-10-16 09:39:53 UTC
I did new installation without removing UEFI boot entries. Everything went fine and system rebooted to freshly installed Fedora.

[root@localhost hrw]# efibootmgr 
BootCurrent: 0000
Timeout: 2 seconds
BootOrder: 0002,0000,0001
Boot0000  USB GRUB
Boot0001  Rawhide
Boot0002* Fedora

Comment 15 Marcin Juszkiewicz 2014-10-30 12:54:22 UTC
Upgraded to 0.13 firmware and did test installs.

1. UEFI has 2 boot entries

Fedora 21 alpha installer added 3rd option and rebooted to freshly installed F21. No issues.

2. UEFI without boot entries

Before installation I went to UEFI boot manager and removed all entries. Then booted installer. Installation went fine and then:

13:09:34,845 ERR anaconda: bootloader.write failed: failed to remove old efi boot entry.  This is most likely a kernel bug.

After reboot there were no boot entries defined. Grub is properly installed and boots but boot entry needs to be added.

Comment 16 Paul Whalen 2014-11-26 20:27:16 UTC
Reopening, this is still happening in TC2.

Comment 17 Paul Whalen 2014-11-28 21:09:19 UTC
With F21 TC2 this only occurs when 'PXE' is the first menu entry in uefi (including when it is the sole entry, or another installation is listed second). It does not occur when PXE is listed second in the uefi boot menu, or there is no boot entry at all. After the installation failed to remove the boot entry and continuing the installation the system reboots with no boot entries listed.

Comment 18 Paul Whalen 2014-11-28 21:11:03 UTC
Created attachment 962587 [details]
storage log

Comment 19 Paul Whalen 2014-11-28 21:11:44 UTC
Created attachment 962588 [details]
program log

Comment 20 Paul Whalen 2014-11-28 21:12:11 UTC
Created attachment 962589 [details]
packaging

Comment 21 Paul Whalen 2014-11-28 21:12:37 UTC
Created attachment 962590 [details]
anaconda log

Comment 22 Marcin Juszkiewicz 2014-12-03 11:55:51 UTC
Grabber RC1.1 image. Did two installations. First one was with one boot entry present. F21 got installed and after reboot I landed in F21 nicely. Old boot entry was preserved.

Removed all boot entries and did second installation. After reboot EFI read F21 boot entry and booted just into F21 system.


Note You need to log in before you can comment on or make changes to this bug.