Bug 11516 - modules not loading after upgrade from 6.0
modules not loading after upgrade from 6.0
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-19 01:37 EDT by wkuhn
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-06 17:58:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wkuhn 2000-05-19 01:37:00 EDT
I upgraded from 6.0 to 6.2 tonight and upon rebooting I was unable to get
a ppp connection.  In /var/log/messages I saw complaints about ppp not
being part of the kernel.  I thought this odd since all I did was upgrade
all installed packages without changing anything else during the upgrade
process.

output from /sbin/lsmod returns nothing.  /sbin/modprobe ppp confirms that
ppp is not installed.

I did notice that there is two module directories under /lib/modules:
2.2.12-20 and 2.2.14-5.0.  2.2.12-20 is *empty* except for a file
modules.dep.  2.2.14-5.0 has directories beneath it containing .o files
which, I'm guessing are the module files.

I tried to "trick" the system into using the modules in the 2.2.14-5.0
directory by moving 2.2.12-20 to 2.2.12-20.orig and making a sym link from
2.2.12-20 to 2.2.14-5.0.  That failed miserably with a lot of "unresolved
symbol" errors at startup.

How can I fix the problems caused by the installer during the upgrade?  I
think the installer has a bug because I really didn't do anything out of
the ordinary during the upgrade and now my system is unusable (I rely on
dialup access).

Thanks in advance for your assistance.

-Bill Kuhn
Comment 1 Jan Welti 2000-05-19 13:21:59 EDT
I believe the installer upgraded your kernel from 2.2.12-20 to 2.2.14-5.0. The
updated kernel hasn't maybe got PPP support. Try compiling a new kernel, this
process begins by running make config in /usr/src/linux.

***TIP: You can use xconfig or menuconfig instead of config!***
Comment 2 Michael Fulbright 2000-08-17 17:41:13 EDT
The 6.2 kernel does contain the ppp module. Perhaps you made some custom changes
to your kernel
and some of the links are confused.

Could you give me the output of the commands 'uname -a' and 'ls -l
/lib/modules'?
Comment 3 Michael Fulbright 2000-10-06 17:58:18 EDT
Please reopen this bug if you continue to have problems.

Note You need to log in before you can comment on or make changes to this bug.