Bug 1151603 - subnet occasionally not appearing in nic assignment screen - HA deployment [NEEDINFO]
Summary: subnet occasionally not appearing in nic assignment screen - HA deployment
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: ruby193-rubygem-staypuft
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: z2
: Installer
Assignee: Brad P. Crochet
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-10 19:22 UTC by Balaji
Modified: 2014-11-04 17:03 UTC (History)
9 users (show)

Fixed In Version: ruby193-rubygem-staypuft-0.4.7-1.el6ost
Doc Type: Bug Fix
Doc Text:
During NIC assignment, the installer builds a list of available subnets by querying all the host's NICs for subnets that are currently unassigned. However, the query also incorrectly considered VIP interfaces as 'assigned', thereby filtering them out from the list (and, consequently, making them unavailable for assignment). With this release, the query no longer filters out VIP interfaces.
Clone Of:
Environment:
Last Closed: 2014-11-04 17:03:23 UTC
Target Upstream Version:
ddomingo: needinfo? (bjayavel)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1800 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Installer Bug Fix Advisory 2014-11-04 22:00:19 UTC

Description Balaji 2014-10-10 19:22:17 UTC
Description of problem:
During deployment, the first controller node has external subnet missing. After host assignment, when the subnets are assigned to the NICs (as part of the "configure Network" for the hosts)the external subnet goes missing on the host that was assigned first(This is the node with all the VIPs assigned). All other hosts see all the subnets. 

Version-Release number of selected component (if applicable):
Rhel-osp-installer A1 release.

How reproducible:


Steps to Reproduce:
1.Deploy an HA environment
2.
3.

Actual results:
External subnet goes missing in the host that was assigned first to the controller node.

Expected results:
All network subnets should be available to be assigned appropriately.

Additional info:

Workaround:

After three hosts have been assigned to controller host group, go to the configure network section, assign the subnets to NICs on the other two nodes. Unassign the node that has "external" missing. Reassign the host to the controller again. You should see all the network subnets now. Complete network assignments on this host. (Initially the VIPs would have been assigned to this host. During "unassignment", all the VIPs are transferred to one of the other two hosts and are intact).

Comment 3 Scott Seago 2014-10-14 14:31:30 UTC
So one question here: What network traffic types are assigned to which subnets?

Comment 4 Balaji 2014-10-14 14:44:00 UTC
External and Public API are assigned to external subnet (this is the one missing on the first node)
Tenant is assigned to tenant subnet.
All the rest are assigned to default subnet.

Comment 5 Scott Seago 2014-10-15 14:35:53 UTC
I think this is already fixed on A2. Looking at the A1 and A2 code diffs, it looks like A1 does indeed have code that would lead to this, but A2 seems to resolve it, as a side effect of the bonding support changes.

Comment 6 Mike Burns 2014-10-15 16:06:53 UTC
Moving this to ON_QA and TestOnly based on Comment 5

Comment 8 Alexander Chuzhoy 2014-10-16 21:37:43 UTC
Verified:
openstack-foreman-installer-2.0.30-1.el6ost.noarch
rhel-osp-installer-0.4.4-1.el6ost.noarch
openstack-puppet-modules-2014.1-24.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch

The reported issue doesn't reproduce.
See all the configured NICs on the firstly added controller.

Comment 9 Alexander Chuzhoy 2014-10-17 18:50:17 UTC
Reproduced:

Environment:
openstack-foreman-installer-2.0.30-1.el6ost.noarch
rhel-osp-installer-0.4.4-1.el6ost.noarch
openstack-puppet-modules-2014.1-24.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch


How to reproduce:
1. After assigning hosts to deployment:
Go to: Hosts -> Assigned -> Select a host -> click on "Configure Network", the subnet including the  "public api" role isn't available for assigning on one controller  out of 3 - the one with vips on it.

Comment 10 Alexander Chuzhoy 2014-10-17 19:04:47 UTC
This is related to 3 roles: public api, admin api, management.
Not just public api.

Comment 11 Mike Burns 2014-10-17 19:44:15 UTC
I can fairly reliably reproduce this by:

create HA deployment
put public-api, management and/or admin-api on a subnet that is *not* default/provisioning
assign 1 host to controller role
configure nics on the controller host
the subnet with admin/management/pulbic-api will not appear.

workaround:  choose multiple hosts to assign at the same time.

Comment 12 Brad P. Crochet 2014-10-20 13:50:03 UTC
PR available: https://github.com/theforeman/staypuft/pull/353

Comment 13 Jason E. Rist 2014-10-20 22:04:48 UTC
Merged.

Comment 15 Alexander Chuzhoy 2014-10-21 20:31:05 UTC
Verified:
Environment:
openstack-puppet-modules-2014.1-24.el6ost.noarch
rhel-osp-installer-0.4.5-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-foreman-installer-2.0.30-1.el6ost.noarch
ruby193-rubygem-staypuft-0.4.8-1.el6ost.noarch


The reported issue doesn't reproduce.
All the configured subnets are available for assignment.

Comment 19 errata-xmlrpc 2014-11-04 17:03:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1800.html


Note You need to log in before you can comment on or make changes to this bug.