Bug 1151606 - public vips not populated (blocker)
Summary: public vips not populated (blocker)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: ruby193-rubygem-staypuft
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: z2
: Installer
Assignee: Brad P. Crochet
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-10 19:32 UTC by Balaji
Modified: 2014-11-04 17:03 UTC (History)
8 users (show)

Fixed In Version: ruby193-rubygem-staypuft-0.4.10-1.el6ost
Doc Type: Bug Fix
Doc Text:
When assigning a subnet to a NIC, the system would remove that subnet from all other NICs including the hidden VIP interfaces. As a result, assigning the Public API, Management and Admin API subnets to any non-provisioning subnet would wipe out the VIP addresses. With this update, when assigning the subnet to a NIC, the subnet is removed from all other interfaces except the VIP interfaces and the VIP addresses remain available on the interfaces.
Clone Of:
Environment:
Last Closed: 2014-11-04 17:03:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1800 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Installer Bug Fix Advisory 2014-11-04 22:00:19 UTC

Description Balaji 2014-10-10 19:32:25 UTC
Description of problem:
public vips not populated during HA deployment

Version-Release number of selected component (if applicable):
Rhel-osp-installer A1 release

How reproducible:
HA deployment

Steps to Reproduce:
1.Assign the hosts during deployment, select hosts -->edit-->Network and scroll down to the NICs to see if the IPs have been populated
2.
3.

Actual results:
Occassionally the NICs are blank with no subnet or IPs assigned

Expected results:
All the NICs and virtual NICs should have been assigned appropriate subnet and IPs/VIPs

Additional info:

This is a blocker since the right subnet has to be assigned to each NIC or virtual NIC. Manual assignment may cause mismatch will result in deployment to fail.

Comment 3 Scott Seago 2014-10-15 15:39:45 UTC
Could you re-test this on an A2 build? Some things have changed around this and this would minimize the chances of us trying to chase something down that's no longer an issue. If you can reproduce this on an A2 build, I'd like to poke around and see what's going on there myself.

Comment 5 Alexander Chuzhoy 2014-10-17 18:08:49 UTC
Verified: FailedQA


Environment:
openstack-foreman-installer-2.0.30-1.el6ost.noarch
rhel-osp-installer-0.4.4-1.el6ost.noarch
openstack-puppet-modules-2014.1-24.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch



The IP is listed on the NICs, but the subnet isn't specified (except for the primary interface).

Comment 6 Mike Burns 2014-10-17 20:42:32 UTC
Some more information and steps:

* Create HA deployment
* create subnets
* assign public_api and/or management and/or private_api to a subnet that is *not* default/provisioning
* discover hosts (at least 3 for controllers)
* assign 1 host to controller role
* open the details of that host ->  you'll see the vips in the network tab which are all assigned correctly
* assign other hosts to controller role
->  vips are still correct
* configure nics on all the controller hosts
* assign the networks (including the vip networks)
* check the host with the vips again (it will have the vip's wiped)

Comment 7 Brad P. Crochet 2014-10-20 15:57:00 UTC
Should be fixed by: https://github.com/theforeman/staypuft/pull/353

Comment 9 Alexander Chuzhoy 2014-10-21 20:27:03 UTC
Verified: FailedQA

Environment:
openstack-puppet-modules-2014.1-24.el6ost.noarch
rhel-osp-installer-0.4.5-1.el6ost.noarch
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
openstack-foreman-installer-2.0.30-1.el6ost.noarch
ruby193-rubygem-staypuft-0.4.8-1.el6ost.noarch

The subnet is specified on all interfaces with IP except for the interface from the subnet with the external role assigned to it.

Comment 10 Brad P. Crochet 2014-10-22 12:07:40 UTC
PR available: https://github.com/theforeman/staypuft/pull/360

Comment 13 Alexander Chuzhoy 2014-10-24 15:38:55 UTC
Verified:
ruby193-rubygem-foreman_openstack_simplify-0.0.6-8.el6ost.noarch
rhel-osp-installer-0.4.5-2.el6ost.noarch
openstack-puppet-modules-2014.1-24.1.el6ost.noarch
openstack-foreman-installer-2.0.31-1.el6ost.noarch
ruby193-rubygem-staypuft-0.4.10-1.el6ost.noarch


The issue didn't reproduce - all the VIPs are listed, and the subnet is shown.

Comment 15 errata-xmlrpc 2014-11-04 17:03:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1800.html


Note You need to log in before you can comment on or make changes to this bug.