Bug 1151616 - vip mac address conflicts when more than 1 HA deployment
Summary: vip mac address conflicts when more than 1 HA deployment
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: ruby193-rubygem-staypuft
Version: 5.0 (RHEL 7)
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: z2
: Installer
Assignee: Scott Seago
QA Contact: Ofer Blaut
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-10 19:41 UTC by Balaji
Modified: 2014-11-04 17:03 UTC (History)
6 users (show)

Fixed In Version: ruby193-rubygem-staypuft-0.4.5-1.el6ost
Doc Type: Bug Fix
Doc Text:
Previously, when deploying an High Availability (HA) environment, VIP interfaces were created with pre-defined MAC addresses. As a result, when a second HA environment was defined, the MAC addresses already existed causing an error. With this update, the pre-defined MAC addresses are generated differently to prevent conflicts. As a result, multiple HA environments are now available.
Clone Of:
Environment:
Last Closed: 2014-11-04 17:03:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1800 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Installer Bug Fix Advisory 2014-11-04 22:00:19 UTC

Description Balaji 2014-10-10 19:41:49 UTC
Description of problem:
When there is more than 1 HA deployment, there is a possibility of conflict (duplication) in MAC address of the VIPs, causing a failure in controller host assignment with the message that the MAC is already existing in an another host.  

Version-Release number of selected component (if applicable):
rhel-osp-installer A1 release

How reproducible:
Deploy with an existing HA deployment

Steps to Reproduce:
1.
2.
3.

Actual results:
Host assignment fails with the message that a MAC is already assigned to a different host.

Expected results:
Host assignment should succeed to the controller host group.

Additional info:

Currently cannot proceed unless the old deployment has been deleted. However the other deployment may need to be preserved for future scaling etc.

Comment 3 Scott Seago 2014-10-13 19:26:24 UTC
The issue is that for the (fake) interfaces we have to create internally to foreman to facilitate IP address reservation, we were just setting the mac addr to 00:00:00:00:00:xx" where the 'xx' corresponds to the VIP number (sequentially from 01).

I've modified this to include deployment ID in the scheme.

https://github.com/theforeman/staypuft/pull/349

Comment 7 Ofer Blaut 2014-10-26 11:36:20 UTC
Issue is not seen on rhel-osp-installer-0.4.5-2.el6ost.noarch

Comment 9 errata-xmlrpc 2014-11-04 17:03:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2014-1800.html


Note You need to log in before you can comment on or make changes to this bug.