Bug 1151739 - typo error in man page of virt-edit
Summary: typo error in man page of virt-edit
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libguestfs
Version: 6.6
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Richard W.M. Jones
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On: 1151738
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-11 08:57 UTC by Lingfei Kong
Modified: 2015-07-22 05:55 UTC (History)
8 users (show)

Fixed In Version: libguestfs-1.20.11-12.el6
Doc Type: Enhancement
Doc Text:
Minor fixes and improvements have been done to the help message of the "set-append" command, an error message of the "guestfish umount" command, and to the guestfish(1) and virt-edit(1) man pages.
Clone Of: 1151738
Environment:
Last Closed: 2015-07-22 05:55:37 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1444 normal SHIPPED_LIVE libguestfs bug fix and enhancement update 2015-07-20 18:44:02 UTC

Description Lingfei Kong 2014-10-11 08:57:05 UTC
+++ This bug was initially created as a clone of Bug #1151738 +++

Description of problem:
virt-edit doesn't support --format raw, it only support --format=raw, so line '--format raw|qcow2|...' should change to '--format=raw|qcow2|...' in man virt-edit


Version-Release number of selected component (if applicable):
libguestfs-1.27.62-1.1.el7


How reproducible:
100%


Steps to Reproduce:
1. Prepare a rhel guest image: rhel.img
2. Read man virt-edit, search --format raw
3. #virt-edit --format raw -a rhel.img  /etc/hosts


Actual results:
#virt-edit --format raw -a rhel.img  /etc/hosts
libguestfs: error: download: download_stub: path must start with a / character


Expected results:
command 'virt-edit --format raw -a rhel.img  /etc/hosts' should give a proper error message,such as:
#virt-edit --format raw -a rhel.img
Try `virt-edit --help' for more information.


Additional info:

Comment 3 Hu Zhang 2014-12-10 10:07:34 UTC
Verified with he Packages Version:
libguestfs-1.20.11-12.el6.x86_64

Verify steps:
1. Read man virt-edit, search --format
   The description is changed from
    ...
    --format raw|qcow2|..
    ...
   to
    ...
    --format=raw|qcow2|..
    ...


Verified.

Comment 6 errata-xmlrpc 2015-07-22 05:55:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1444.html


Note You need to log in before you can comment on or make changes to this bug.