Bug 115177 - init script stop fails on kernel 2.6
init script stop fails on kernel 2.6
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pcmcia-cs (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-07 20:59 EST by Jost Diederichs
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-08 02:59:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jost Diederichs 2004-02-07 20:59:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040124

Description of problem:
1) the init script will not unload the ds module during the stop command
2) the stop command should also call "cardctl eject"

fix:
1) the line
    if grep -q "ds " /proc/modules ; then
must only contain one space after ds, not two
2) the stop section of the script needs a "cardctl eject":
    stop)
        echo -n "Shutting down PCMCIA services: "
        if [ -s /var/run/cardmgr.pid ] ; then
            cardctl eject
            PID=`cat /var/run/cardmgr.pid`
            kill $PID
            # Give cardmgr a few seconds to handle the signal
            for N in 1 2 3 4 5 1 2 3 4 5 1 2 3 4 5 ; do
                kill -0 $PID 2>/dev/null || break
                sleep 2
            done
        fi
        killall -q "CardBus Watcher"
        if grep -q "ds " /proc/modules ; then
            /sbin/rmmod ds
            /sbin/rmmod $PCIC 2>/dev/null || \
                /sbin/rmmod yenta_socket 2>/dev/null
            /sbin/rmmod pcmcia_core
        fi
        echo "done."
        rm -f /var/lock/subsys/pcmcia

        # we do this because when we stop the service, the ide stop script
        # gets run before the card disappears
        /usr/sbin/updfstab
        EXITCODE=0
        ;;


Version-Release number of selected component (if applicable):
pcmcia-cs-3.2.7-1.3

How reproducible:
Always

Steps to Reproduce:
1. with a wireless network card active
2. execute "service pcmcia stop" or run "shutdown"

    

Actual Results:  modules ds, yenta_socket and pcmcia_core don't unload
and the kernel crashes during shutdown 

Expected Results:  pcmcia modules should be unloaded after executing
the stop script

Additional info:
Comment 1 Bill Nottingham 2004-09-08 02:59:17 EDT
unloading fixed in 1.9.

Note You need to log in before you can comment on or make changes to this bug.