Bug 1151830 - Race-condition w/ integrated SPICE/VNC console which leads to SPICE/VNC display freeze
Summary: Race-condition w/ integrated SPICE/VNC console which leads to SPICE/VNC displ...
Status: CLOSED NOTABUG
Alias: None
Product: Virtualization Tools
Classification: Community
Component: virt-manager
Version: unspecified
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Cole Robinson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-10-12 12:33 UTC by Matthias Dahl
Modified: 2014-10-14 14:59 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-10-14 14:59:12 UTC


Attachments (Terms of Use)

Description Matthias Dahl 2014-10-12 12:33:33 UTC
Description of problem:
My test scenario is a simple KVM image created through virt-manager w/ Spice, QXL 64 MiB, 2 GiB RAM, 4 Cores and no disks at all -- just a plain old LiveCD attached to the CDROM.

Starting this (or any other) VM through virt-manager so that it opens the UI-integrated SPICE/VNC console, leads to a malfunctioning SPICE/VNC console. There seems to be a race-condition: Sometimes you can only see the SeaBIOS text, sometimes even that only partially and sometimes it even gets to the LiveCD prompt itself but that is as far as it goes. Eventually the console is no longer updated.

Connecting to the VM through an external Spice or VNC client works just fine and the VM is up and running as well.

Version-Release number of selected component (if applicable):
virt-manager: 1.0.1, 1.1.0 and master.
libvirt: 1.2.6 and 1.2.9.
spice-gtk: 0.25 and master
qemu: 2.1.1
Kernel: 3.16.1

How reproducible:
always

Steps to Reproduce:
1. Create a VM for Qemu w/ only a LiveCD attached (no disks whatsoever)
2. Configure the VM for either VNC or SPICE
3. Start the VM through virt-manager

Actual results:
Console freezes at random points but always within a second or so.

Expected results:
Console just works.

Additional info:

Comment 1 Matthias Dahl 2014-10-14 14:59:12 UTC
After wading through the virt-manager sources and debugging this, I eventually came to realize that this seemingly is a cairo problem that surfaces if the xlib-xcb adapter is enabled.

For completeness, here a link to the relevant bug report:
https://bugs.freedesktop.org/show_bug.cgi?id=85005

Sorry for the noise. :-(


Note You need to log in before you can comment on or make changes to this bug.